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Preface

This manual supports the following WaveStar� software products:

� WaveStar Software for Oscilloscopes (WSTRO) lets you control,
capture, display, analyze, measure, and document oscilloscope
signal waveforms on your PC.

� WaveStar Software DEMO is a free, fully-functional version of
WaveStar with a 30-day use limit.

� WaveStar Software Reader is a free application that lets you view
data sheet and notebook files created by WaveStar Software for
Oscilloscopes. You can load WaveStar Reader on any number of
PCs.

This manual is organized to cover all common information about
WaveStar Software, and also includes specific information for each
product where applicable.

This manual describes system requirements, installation, operating
basics, data sheet overview and procedures, RS-232 and GPIB
reference information, the WaveStar Instrument Manager Service,
and the WaveStar User Table Proxy application. Refer to the online
help for further information on the topics in this manual and for
information on the user interface and advanced procedures.
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The following table lists all of the documents included with your
purchase and the purpose of each document.

Documentation Set

Document Purpose and description

User Manual Instructional manual that details the application,
procedures, contacting Tektronix, and many other
aspects of the product. Use this manual together
with the online help.

Software License
Agreement Envelope

Envelope that contains the CD-ROM and software
key. The Tektronix Software License Agreement is
printed on this envelope. Breaking the envelope seal
means that you agree with the terms outlined in the
agreement.

Software Key Label, located on the back of the CD-ROM software
installation instruction booklet, that contains a
14-character software installation key that you are
required to enter when you install this software. You
will be asked to enter this key each time you install
this software. You will not be able to install the
software without it. Do not lose the label.

CD-ROM booklet Contains installation information for each product on
the CD-ROM disc.

Business Reply Card Complete and return the business reply card to
register your product.
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Contacting Tektronix

Phone 1-800-833-9200*

Address Tektronix, Inc.
Department or name (if known)
14200 SW Karl Braun Drive
P.O. Box 500
Beaverton, OR 97077
USA

Web site www.tektronix.com

Sales sup-
port

1-800-833-9200, select option 1*

Service
support

1-800-833-9200, select option 2*

Technical
support

Email: techsupport@tektronix.com

1-800-833-9200, select option 3*

6:00 a.m. -- 5:00 p.m. Pacific time

* This phone number is toll free in North America. After office hours,
please leave a voice mail message.

Outside North America, contact a Tektronix sales office or distributor;
see the Tektronix web site for a list of offices.
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Product Description

WaveStar Software is an application that connects your Tektronix
TDS/THS and CSA oscilloscopes to your PC desktop. Its features
include:

Capture

The WaveStar software provides the following features for setting up
and capturing data:

� Set up communication to instruments through the WaveStar
Connection Wizard.

� Use the WaveStar Explorer view to display connected instru-
ments and capture measurement waveforms and data easily
without the need for programming.

� Drag and drop instrument data into an active data sheet.

Analyze

The WaveStar software provides the following features for data
analysis:

� Analyze, annotate, and record information in a variety of data
sheets.

� Capture and graphically view multiple waveforms on a graticule
with the same scale and position as on the oscilloscope.

� Take measurements easily using zoom function.
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Control

The WaveStar software provides the following control features:

� Step away from your desk and have WaveStar automatically
capture data changes.

� Establish instrument links to automatically update new
measurements.

� Control waveform information locally or over the network.

Document

The WaveStar software provides the following documentation and
print features:

� Archive information in Microsoft Office or other Microsoft
Windows applications.

� Print banner function allows printing of long record length
waveforms.

Create Masks

The WaveStar software provides the following mask creation
features:

� Copy and load instrument test masks to or from YT data sheets.

� Edit masks in an intuitive, easy-to-use graphical editor.

� Load test masks from the WaveStar Mask Library.

� Create masks from scratch.

Distribute

The WaveStar Reader software provides the following features:

� Open, view, and manipulate existing WaveStar notebook and data
sheet files.

� You can load WaveStar Reader onto as many PC’s as you like.

� You cannot create new data sheets. You can save existing data
sheets and notebooks to new file names.

� You cannot link WaveStar Reader to an instrument.
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System Requirements

To install and run WaveStar software, you must have an IBM-com-
patible PC with the following installed:

� Microsoft Windows 98SE, ME, NT4.0 service pack 6, 2000, or
XP Professional operating system PC

� 128 MB RAM or greater recommended

� CD-ROM drive, 4X or better drive speed

� SVGA monitor or better

� 40 MB disk space

� Appropriate interface hardware to connect your PC to an
oscilloscope:

� National Instruments or equivalent IEEE 488.2 GPIB
Interface Card and driver software

� RS-232 serial communications port and RS-232 cable

� 10/100BaseT compatible Ethernet port or card

When using the Tektronix AD007 GPIB-LAN Adapter, you can
connect directly to the 10/100BaseT LAN (local area network)
connector with a RJ-45 UTP cable (provided with your AD007
GPIB-LAN Adapter). For a complete list of the system requirements
for the AD007 Adapter, refer to the AD007 GPIB-LAN Adapter User
Manual.
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Supported Instruments

For a list of supported products, please see the installation instruction
booklet included with the CD-ROM.
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Installing and Running WaveStar

This section describes how to install WaveStar, set up instrument/PC
communications, run WaveStar, and uninstall WaveStar software.

Installing WaveStar Software

To install WaveStar software, follow the installation instructions in
the Tektronix Software Solutions Installation manual that is enclosed
with the Software Solutions CD. This installation manual is also
located as a PDF file in the CD Documents directory.

Setting Up PC to Instrument Communications

You must establish a communication link from your PC to an
instrument before running WaveStar. WaveStar uses Virtual
Instrument Software Architecture (VISA) to communicate with
instruments. The Tektronix version of VISA (referred to as
TekVISA) is required to run WaveStar.

NOTE. TekVISA does not support VXI Mainframe communication.

To establish communications between WaveStar and instruments,
first run the TekVISA Configuration utility to locate and register
instruments. Then run the Instrument Manager Service (IMS)
program to enable communications between the instrument and
WaveStar.

The following sections describe how to use these programs to set up
instrument communications.
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Running the TekVISA Resource Manager Configuration Program

Run the TekVISA Resource Manager Configuration program to
configure TekVISA preferences, locate, and add instruments.

1. Right-mouse click on the yellow VISA icon in the Taskbar
notification area to display a pop--up menu. This icon was
installed as part of the WaveStar/TekVISA installation. If this
icon is not present, select Start > Programs > TekVISA >
TekVISA Configuration and wait for the icon to appear in the
Taskbar notification area.

2. Select Preferences to display the TekVISA Resource Manager
Preferences dialog. Use the dialog to specify which communica-
tion ports and how often you want TekVISA to search for
instruments. The search preferences have different settings
depending on whether TekVISA is installed on a Windows-based
oscilloscope or a PC. Pressing the Default Preferences button on
the Preferences dialog will set the configuration utility to
automatically search for instruments on RS-232, LAN and GPIB
ports.

Once the appropriate selections are made on this dialog, select
OK to close the dialog.

3. From the yellow TekVISA icon pop-up menu, select Refresh to
refresh connected instrument information.

4. From the yellow TekVISA icon pop-up menu, select Configure...
to display the TekVISA Resource Manager Configuration dialog.
Wait until the message Status: Ready is displayed in the lower
left corner.



Installation and Uninstallation

WaveStar Software User Manual 1- 7

5. Check that the instrument you want to communicate with is listed
in the TekVISA Resources field. If the LAN-connected
instrument with which you want to communicate is not listed, do
these steps to add an instrument to the Remote Host List:

NOTE. If you are attempting to communicate with a Tektronix
Windows-based oscilloscope, make sure the VXI--11 server is running
on the oscilloscope before doing the following procedure.

a. Select the Add button in the Remote Host List area. This
opens the Add Remote Host dialog.

b. Enter the IP address or location name (some instruments
use the VXI-11 server to define a name) in the Host Name
field.

c. Select OK. The dialog closes, returns to the main
TekVISA window, and adds the IP address or location
name to the Remote Host field.

d. Select the Find button. The utility attempts to locate the
specified remote host address and lists it in the TekVISA
Resources field. It may take the program a few moments
to locate instruments, depending on network speed and
load.

NOTE. The TekVISA Resource Manager Configuration program must
be able to locate and register an instrument before you can use IMS
to set up communications with connected instruments.

If the TekVISA Configuration utility cannot locate an instrument,
refer to the troubleshooting bullet items on page 1--9. Also refer to
the TekVISA Release Notes and TekVISA Resource Manager Help
items in the Start > Programs > TekVISA menu for more informa-
tion.
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e. Repeat steps a through d to continue adding instrument
addresses.

f. Select the X button in the upper right corner to save your
changes and exit the TekVISA Resource Manager
Configuration utility program.

Running the Instrument Manager Service (IMS)

To open a communication connection between a PC and a connected
instrument, do the following:

1. Run the IMS program:
Start > Programs > WaveStar for Oscilloscopes > Instrument

Manager

The program opens the IMS window and then opens the Instrument
Connect wizard if there are no defined instruments.

2. Select the instrument family to which you want to connect.

3. Select Next. The program searches the PC communication ports
for instrument addresses and lists them in the instrument field. If
IMS does not find an instrument that is connected to your PC or
LAN, verify that the instrument and PC communication settings
(such as baud rate, stop bits, and so on, for RS-232) are the same
and that the instrument is powered on.

4. Select the instrument to which you want WaveStar to connect.

5. Select Next. The connection wizard displays an alias field in
which you can enter a name or label for the instrument. This alias
appears in the WaveStar instrument explorer view, and makes it
easier to identify an instrument (for example, TDS3K-QualLab).
If you do not enter an alias, IMS and WaveStar use the
instrument series as the alias (for example, TDS3000B).

6. Select Next. The connection wizard displays a Configure button
that lets you change PC communication settings for the selected
instrument communication protocol, restore default settings, or
test new settings.

7. Select Next. The connection wizard displays a Test button that
lets you test the selected instrument communication connection
and returns a pass or fail message.
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8. Select Next. The connection wizard displays a connection
verification message.

9. Select Finish to close the connection wizard and return to the
IMS window.

10.To add more instruments, select Edit > Add Instrument... from
the IMS menu and repeat steps 2 through 9.

11.Minimize the IMS window. You are now ready to run WaveStar.

Troubleshooting IMS/PC Communications Problems

If IMS cannot locate a particular instrument that you know is
connected to a LAN, work with your system administrator to resolve
the problem. Some items to check for are:

� The IP address you are looking for is actually assigned to the
correct instrument.

� The instrument LAN settings are correct.

� The instrument is powered on.

� You have network access permissions if you are connecting to an
instrument through multiple networks or firewalls.

� Run the TekVISA Configuration program to locate and register
the instrument (see page 1--6).

� Refer to the Instrument Manager Service (IMS) section of this
manual (starting on page 2--1) for more information on using the
IMS program.

Running WaveStar for Oscilloscopes or WaveStar Reader

To run WaveStar for Oscilloscopes or WaveStar Reader, select
Start > Programs > WaveStar for Oscilloscopes > WaveStar for
Oscilloscopes.

Refer to the rest of this manual, as well as the WaveStar online help,
for information on running WaveStar Software for Oscilloscopes or
the WaveStar Reader.



Installation and Uninstallation

1- 10 WaveStar Software User Manual

Uninstalling WaveStar

To uninstall WaveStar for Oscilloscopes software, use the
Add/Remove program in the Microsoft Windows Control Panel to
activate the Uninstall wizard, which takes you through the uninstall
process for the selected software.
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Instrument Manager Service (IMS)

The Instrument Manager Service (IMS) application connects your
PC to an instrument and displays connectivity status information.
Any connections you make during a session are saved when you exit
the IMS program.

To run the IMS program, select Start > Programs > WaveStar for
Oscilloscopes > Instrument Manager

The program opens the IMS window. If there are no defined instru-
ments, IMS automatically opens the Instrument Connect wizard.

Main Screen

The illustration below shows the Instrument Manager Service main
screen.
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Menu Bar

The menu bar contains five menus, each with submenu commands to
control the application.

Control

Refresh Lists Refreshes the instrument list and updates the
connection status of all instruments.

Auto Shutdown Configures the application to automatically shut
down the Instrument Server when you exit the
IMS.

Connect Service Configures the connection to the Instrument
Server.

Shutdown Service Shuts down the Instrument Server (IS). This
closes the background instrument server
communication connection between instruments
and WaveStar.

Exit User Interface Exits the Instrument Manager and leaves the
Instrument Server (IS) running. If Auto Shutdown
is enabled, this command shuts down teh IS and
then exits IMS.

Edit

Add Instrument Adds an instrument to the Instrument Manager list.

Instrument
Properties

Displays the connection properties of the selected
instrument.

Delete Instrument Deletes the selected instrument from the
connection list.

Switch Instrument Toggles the selected instrument connection
between online and offline. You select the
instrument in the IMS main window.
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View

Toolbar Turns the toolbar on and off.

Status Bar Turns the status bar on and off.

Activity Log Turns the activity log display on and off. The
activity log lists the date, time, and results of
communication between the PC and the
instrument.

Print

Activity Log Prints the activity log.

Help

Contents and Index Displays the table of contents and index for the
online help.

What’s This Displays What’s This help on toolbar buttons and
menu items. Select this menu item, and then click
the button or menu item for which you want help.

InstMgr Overview Displays the IMS Window Overview online help
topic.

Technical Support Shows information about contacting Tektronix for
technical help.

About InstMgr Shows the version information for the Instrument
Manager.
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Toolbar

The Instrument Manager toolbar contains buttons that operate as
shortcuts to certain menu commands. Shown below is each button
with a description of what the button controls.

1 2 3 4 5 6 7

Connect to a new instrument.

View the instrument properties of the instrument selected
from the list.

Delete the connection to the instrument selected from the list.

1

2

3

5

6

7

8

Display the Instrument Manager activity log. The activity log lists
communications, including communication errors, between your
PC and your instrument.

Print the Instrument Manager activity log.

Access the online help.

Display What’s This help on toolbar buttons and menu items.
Click this button, and then click the button or menu item for
which you want help.

8

4 Toggles the selected instrument connection between online and
offline. You select the instrument in the IMS main window.
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Instrument List (Main Screen)

The main screen of the Instrument Manager (see page 2--1) shows
all the instruments available for connection and the following
information (from left to right):

� The alias you have assigned each instrument (if available)

� The connection type ASRL (RS-232), GPIB, or TCPIP ports

� The permissions set for each connection

� Software status (running, not running) and hardware status
(responding, not responding)

Adding an Instrument

You must connect your instrument to a PC using a LAN, GPIB, or
RS-232 communication cable, and establish a communications link
between the instrument and WaveStar. Refer to your instrument
documentation to correctly set your instrument communication
protocols and settings. Also refer to page 1--6 in the Getting Started
chapter for steps to set up instrument to PC communications.

Follow the steps below to use the Instrument Manager Service (IMS)
to add an instrument to the IMS instrument list.

1. Power on the instrument.

2. Open the IMS program:
Start > Programs > WaveStar for Oscilloscopes > Instrument

Manager

The IMS program searches for any connected instruments and
lists them in the Instrument List.
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NOTE. If there are no listings, there are no instrument connections
available. You should recheck your instrument-to-PC communication
cables/connections, make sure the instrument power is on, and verify
that both the instrument and PC communication settings are the
same.

3. If the IMS does not find any instruments, it opens the Instrument
Connection wizard. The first screen show a list of supported
instrument series.

4. Select the instrument series to which you want to connect and
then select Next.

5. Connection wizard step 2 lists all available connections to your
PC. Select the desired connection, and click Next.

NOTE. IMS labels Ethernet connections as
TCIP::xxx.xxx.xxx.xxx::INSTR, where xxx is each part of an
IP address.

6. Connection wizard step 3 lets you enter an alias for your
instrument. This will be the name that appears in the IMS Alias
list and in the WaveStar Software instrument explorer view. If
you do not enter a name, the product family name is used by
default. Enter an alias or leave the field blank, and click Next.

7. Connection wizard step 4 lets you change your connection
settings. Click Next to use the current RS-232 or GPIB settings,
or click Configure to display an RS-232 or GPIB settings dialog
box:

RS-232 Settings

Baud. The Baud rate is the speed of communication between
your PC and instrument. The baud rate selected here must match
the baud rate of the instrument to which you are connecting.
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NOTE. Check your instrument’s user manual to determine the
maximum Baud rate. If you have RS-232 communication problems,
select a lower Baud rate.

Stop bits. Stop bits are the number of bits sent with each
character to identify the end of data for that character.

Data bits. Data bits are the number of bits sent for each
character.

Flow control. Flow control is the type of handshaking used to
guarantee accurate transmission of data from one device to
another. This handshaking prevents buffers from overflowing in
the receiving device.

Parity. Parity is the data bit added to each character to validate
its correct transmission.

Terminator. Terminator is the character added to the end of each
command or query to indicate the end of the command or query.

Timeout. Timeout is the length of time the application will try to
communicate with the instrument before aborting the commu-
nication. The default setting is None, which each instrument
interprets differently.

Restore Factory Settings. Uses the RS-232 settings originally
shipped with the selected instrument.

Restore Default Settings. Uses the predefined default settings
for the selected instrument.

GPIB Settings

Terminator. Terminator is the character added to the end of each
command or query to indicate the end of the command or query.

Timeout. Timeout is the length of time the application will try to
communicate with the instrument before aborting the commu-
nication. The default setting is None, which each instrument
interprets differently.

Restore Factory Settings. Restores the GPIB settings originally
shipped with the selected instrument.
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Restore Default Settings. Restores the predefined default
settings for the selected instrument.

If you want to make your new selections the default settings for
GPIB connections, click the Update GPIB Settings button.

When you are finished configuring the settings, click Test New

Settings. If the settings are accepted, a dialog appears telling you
that the device proxy is running and the attached hardware is
responding. Click OK.

8. Connection wizard step 4 dialog appears again. Click Next.

9. Connection wizard step 5 lets you test the communication
settings. Click Test to test your connection. If the connection is
established, the following message appears:

“Device proxy (<Instrument Name>) is running and the
attached hardware is responding.”

If the connection is not established the following message
appears:

“Device proxy (<Instrument Name>) is running but the
attached hardware is not responding. Response string is: ().”

If you get the above message, check the following items:

� The cable or LAN connection between your instrument and
PC.

� You are connected to an available COM port on the PC (for
RS-232).

� The instrument power is on, and that you are using the correct
cable. Refer to System Requirements on page 1--3 for a list of
system and equipment requirements.

Use the Back button to check your settings and reconfigure the
connection.

When you establish a good connection, click Next.

10.Connection wizard step 6: click Finish to add this instrument and
connection to the IMS list.
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Removing an Instrument from IMS

Follow the steps below to remove an instrument from the IMS
application:

1. Open the IMS application.

2. In the Alias list, select the instrument you to remove.

3. Click the tool bar Delete button or select Edit > Delete

Instrument.

Switching an Instrument Online or Offline

You can have more than one instrument listed in the IMS with the
same connection (see the Main Screen illustration on page 2--1).
However, only one of these instruments can be online at any given
time.

To switch an instrument online or offline, follow these steps:

1. Select the instrument you want to switch online or offline in the
IMS main screen.

2. Select Switch Instrument from the Edit menu in the IMS
application. One of the following dialogs will appear:

� If the connection is currently in use with another instrument,
a dialog will appear asking you to verify that you want to
switch that instrument offline before switching the selected
instrument online.

� If the connection for the selected instrument is not in use, a
dialog will appear asking you to verify that you want to
switch the selected instrument online.

NOTE. You can also use the toolbar to switch an instrument online or
offline. Refer to item 4 in the toolbar shown on page 2--4.
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Shutting Down the Instrument Server (IS) Service

The Instrument Server (IS) continues to run in the background, even
when the IMS application user interface is closed (unless it was
specifically shut down from within the IMS program); this is normal
so that WaveStar can access instruments.

To shut down the IS, select Control > Shutdown Service before you
close the IMS application. You can also select Control > Auto
Shutdown to shut down both the Instrument Server and the IMS
application when you exit the application.

Display and Print the IMS Activity Log

The IMS Activity Log shows the time, date, and description of all
communications between WaveStar Software and the instrument.

Display the Activity Log

Follow the steps below to display the IMS activity log:

1. Open the IMS application.

2. Click the View Log button in the IMS toolbar. When the activity
log appears, you can select the following elements:

� Local service activity. Logs communication between the
instrument and WaveStar Software.

� Internal program logic. Logs WaveStar Software operations.

� Refresh button. Updates the activity log.

3. Click OK to dismiss the activity log.

Print the Activity Log

1. From the activity log, click Print; use the print dialog to print the
log.

2. From the IMS window, click Print in the toolbar or select Print
> Activity Log.
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Set Instrument Permissions

1. Open the IMS application and select the instrument whose
permissions you wish to change.

2. Click the toolbar Properties button or select Edit > Instrument
Properties to display the Instrument Properties dialog box.

3. Click the following items to toggle the permissions on or off:

� Read Only

� Read/Write

� Visible

� Activity Logging

4. Click OK to apply your selections; click Cancel to discard them.
Both buttons dismiss the Instrument Properties dialog box.
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Operating Basics

This section outlines WaveStar Software features common to
WaveStar for Oscilloscopes and WaveStar Reader.

Main Screen Overview

The WaveStar window consists of a menu bar, a toolbar, and two
panes: the Explorer View and the Data Sheet Pane. The following
illustration labels each area of the WaveStar window.

Menu bar Toolbar

Explorer View Data Sheet Pane
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Menu Bar

The menu bar contains all commands available in WaveStar. You
access the menu bar commands using standard Window menu
processes. The menu bar is described in more detail on page 3--4.

Toolbar

The toolbar contains shortcuts to the most commonly-used WaveStar
commands. The toolbar is described in more detail on page 3--10.

Explorer View

The Explorer view lists all available instruments and their data,
settings, and controls, in a Windows Explorer-like tree diagram. You
copy and/or link data from an instrument in the Explorer view to a
data sheet in the Data Sheet pane. The Explorer view is described in
more detail on page 3--12.

NOTE. WaveStar Reader does not have the Explorer view.

Data Sheet Pane

The Data Sheet pane contains data sheets that provide an assortment
of ways to display instrument data. In the data sheet pane, you can
do the following tasks:

� Create data sheets for displaying waveforms graphically, such as
strip recordings, as tables, as statistics, or as measurements.

� Transfer data to and display it in the data sheets, using Windows-
standard drag and drop operations.

� Document and analyze data, dragging and dropping it from data
sheets to Microsoft Office applications.

� Display waveforms from one channel or from many in the same
data sheet or in individual data sheets.

� Display the same waveform data graphically, as a table, or both
ways at the same time.
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� Compare waveforms in various views simultaneously, in one or
more data sheets or in a single document (if you drag data from a
data sheet into an MS Word document or Excel spreadsheet).

� Print a monochrome or color hardcopy of your data (depending
on printer abilities).

There are four types of data sheets:

1. Waveform data sheets display instrument waveforms. These data
sheets let you view, record, or analyze waveform data. Available
waveform data sheets are YT, XY, and Power Harmonics.

2. Scalar data sheets display instrument scalar data, such as
measurements and waveform sample points. Available Scalar
data sheets are DatalogMeasurement, DatalogTabular, Scalar-
Viewer, StripChart, WaveformMeasurement, and WaveformTabu-
lar.

3. The Notes data sheet displays graphical copies of waveform or
tabular data, instrument screen copies, instrument settings, and
notes that you add to the sheet.

4. The Instrument Explorer data sheet displays the contents of
instrument hard and floppy drives in an Explorer-like window.

All data sheets in a data sheet pane are part of the current workbook
(.wk file extension). The workbook allows you to organize and save
your data sheets as a single collection. You can also save individual
sheets as files (.sht file extension) and add saved sheets to the current
workbook.

All of these data sheets are described in detail in Section 4,
Data Sheet Overview.
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The WaveStar Menu Bar

The menu bar contains menus and associated submenus that give you
access to all WaveStar command functions. The menu bar is
dynamic; the menus shown, along with their contents, change
depending on which data sheet is active. The following table briefly
describes all possible contents of each menu.

File

New Datasheet... Opens a dialog box that lets you select a data
sheet to add to the data sheet pane.

Open... Opens a dialog box that lets you open a workbook
or data sheet file.

Close Datasheet Deletes the selected data sheet from the
workbook.

Close Workbook Closes the current workbook and clears the data
sheet pane.

Save Datasheet
As...

Opens a dialog box that lets you save the selected
data sheet to a specified directory and file name.
Note that changing the file name will change the
name of the data sheet as displayed in that sheet’s
title bar.

Save Workbook Saves the workbook to its current directory and file
name.

Save Workbook
As...

Opens a dialog box that lets you save the
workbook to a specified directory and file name.

Start Workbook... Starts data acquisition of linked signals for the
workbook. You can select which data sheets will
acquire data. This command does not refresh
copied data or relink unlinked signals.

Stop Workbook... Stops data acquisition of linked signals for the
workbook. You can select which data sheets will
stop acquiring data. This command does not
unlink linked signals.
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File

Auto Versioning Automatically appends date and time information
to data sheet or workbook file names when the file
is saved. This lets you create time-stamped files.

Rename
Datasheet...

Opens a dialog box that lets you rename the
selected data sheet title that appears in the sheet’s
title bar. Note that changing the name will change
the file name of the data sheet, as the data sheet
uses the file name for the title bar label.

Import... Imports the specified file-format contents into the
selected data sheet. Available formats are .CSV,
.WFM, .ISF, and .MSK.

Export
Datasheet �

Exports the selected data sheet’s contents in the
specified data format. Available formats are .CSV,
text, .RTF, and .MSK.

Print Setup... Sets printer parameters including current printer,
page format, number of copies to print, and so on.

Print Preview
Datasheet

Previews the printer output for the selected data
sheet.

Print Datasheet... Prints the selected data sheet to the current
printer.

Print Preview
Workbook

Previews the printer output of all the data sheets in
the workbook.

Print Workbook... Prints all data sheets in the workbook to the
current printer.

Print Banner... Prints long waveforms in banner format.

File Conversion... Converts all saved WaveStar DataSheet (.sht)
files (except NoteSheets) in a selected directory to
Coma Separated Values (.csv) files.
See page 5--14.

Recent File List Displays a list of the most-recent workbooks you
have created or opened. Select to open.

Exit Exits the WaveStar program.
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Edit

Undo Undoes the last Wavestar task action.

Redo Redoes the last Wavestar task action.

Cut Cuts the selected data sheet information to the
Clipboard.

Copy Copies the selected data sheet information to the
Clipboard.

Paste Copies the Clipboard information into the selected
data sheet.

Delete Deletes the selected information from the data
sheet.

Unlink Disconnects the selected data sheet data from its
source. Unlinked data can be relinked using the
Relink command, or refreshed by using the
Refresh Datasheet or Refresh Workbook
commands.

Relink Reconnects the selected data sheet data to its
source. Relink will not create a link to a data
source.

Select All Selects all waveform or data on the selected data
sheet.

New Annotation Opens a dialog box that lets you add notes to the
selected YT, XY, or StripChart data sheet. You can
then select the note text in the data sheet and
move it to the desired location.

Edit Annotation Lets you edit existing annotation text on a YT, XY,
or StripChart data sheet. Select the text to edit,
then select Edit -Edit Annotation. You can also just
double-click on the annotation text to open the edit
dialog box.

Clipboard
Formats...

Selects data formats that can be saved to the
Clipboard. Formats include Comma Separated
Values (CSV), Simple text (ASCII), DIB (Bitmap),
Rich Text Format (RTF), and Enhanced Metafile.
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Edit

Swap XY Swaps the signal sources assigned to the XY
inputs of the XY data sheet.

Find... Opens a dialog box to search the Notes sheet for
a specified text string.

Replace... Opens a dialog box to search the Notes sheet for
a specified text string and replace with another
specified text string.

Copy Voltage
Waveform

Copies the voltage waveform from the Power
Harmonics data sheet.

Copy Current
Waveform

Copies the current waveform from the Power
Harmonics data sheet.

Copy Power
Waveform

Copies the calculated power waveform from the
Power Harmonics data sheet.

View

Toolbar Turns the WaveStar toolbar on or off.

Status Bar Turns the WaveStar status bar on or off.

Explorer View Turns the Explorer view on or off.

Datasheet Toolbar Turns the selected data sheet toolbar on or off.

Mask Editing
Toolbar

Turns the mask editing toolbar on or off.

Datasheet Status
Bar

Turns the selected data sheet status bar on or off.

Refresh Datasheet Updates copied and unlinked data on the selected
data sheet.

Refresh Workbook Updates copied and unlinked data in all data
sheets of the workbook.

Properties... Opens a dialog box to display and set properties of
the selected data sheet.
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View

Show Links... Shows links associated with the selected data
sheet.

Centered
(XY &YT only)

Centers the graticule in the XY or YT sheet
windows. This command is only available when
the graticule is larger than the data sheet window.

Transfer Full Grati-
cule (XY &YT only)

Copies the entire graticule when doing drag and
drop operations to other applications such as
Microsoft Word. If this command is not enabled,
WaveStar copies just the graticule area displayed
in the data sheet window.

Masks (YT sheet only)

New Mask Creates a new mask for a specified oscilloscope
family. You create the mask segments and then
define the mask parameters.

New Segment Creates a small rectangular mask segment in the
upper-left corner of an existing mask. You can
then move the segment, add points, and reshape it
as needed.

Duplicate Segment Copies the active mask segment. You can undo
Duplicate Segment.

Add Point Adds a point (vertex) halfway between a selected
point and the next counterclockwise point. You can
undo Add Point.

Delete Point Deletes the selected mask segment point. You can
undo Delete Point to restore a deleted line point.

Delete Segment Deletes the selected mask segment. You can undo
Delete Segment to restore a deleted segment.

Delete Mask Deletes all mask segments from the YT sheet. You
can undo Delete Mask.

Change Size Changes overall size of a segment using specified
values.
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Masks (YT sheet only)

Set Units Sets amplitude/time or Divisions as the mask
segment position units.

Tabular View Displays the active mask segment coordinates in
tabular form. You can edit the table entries for
more precise control of the segment coordinates.
You can also enter mask parameters by selecting
the Edit Parameters button

Format (Notes sheet only)

Fonts... Selects the font typeface and size to use when
adding text to the Notes sheet.

Color... Selects the font color to use when adding text to
the Notes sheet.

Alignment Selects the font word-wrap and text alignment
characteristics to use when adding text to the
Notes sheet.

Window

Cascade Stacks open data sheets in a diagonal overlap,
starting from the upper left corner of the data
sheet pane.

Tile Resizes data sheets in the data sheet pane so that
all sheets are visible and do not overlap.

New Window Opens a new Instrument Explorer data sheet in
the sheet pane.

Arrange Icons Lines up minimized data sheet icons along the
bottom of the data sheet pane.

Help

Contents and Index Displays the table of contents and index for the
online help.

What’s This Displays What’s This help on toolbar buttons and
menu items. Select this menu item, and then click
the button or menu item for which you want help.
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Help

WaveStar
Introduction

Opens a window that displays WaveStar
introductory information.

WaveStar Overview Displays the WaveStar Overview online help topic.

Technical Support Shows information about contacting Tektronix for
technical help.

About WaveStar... Shows WaveStar version information.

The WaveStar Toolbar

The following figure and table describe the function of each toolbar
button.

1 2 3 4 5 6 7 8 9

10 11 12 13 14 15 16 17

Item Button name Description

1 New Datasheet Opens a dialog box that lists available data
sheets. Select a data sheet and click OK to load
into the data sheet pane.

2 Open Opens a dialog box to let you load saved data
sheet (*.sht), workbook (*.wbk), or WSTR31
notebook (*.nbk) files.

3 Save Datasheet Opens a dialog box to let you save the selected
data sheet to a specified location and file name.
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Item DescriptionButton name

4 Save Workbook Opens a dialog box to let you save the workbook
to a specified location and file name. A workbook
consists of all data sheets loaded into the data
sheet pane.

5 Cut Cuts the contents of the selected data sheet to
the Clipboard.

6 Copy Copies the contents of the selected data sheet to
the Clipboard.

7 Paste Copies the contents of the Clipboard to the
selected data sheet.

8 Unlink Disconnects the link between the selected data
target on a data sheet and its source signal or
measurement.

9 Relink Reconnects a link between the source signal or
measurement and the selected data target on a
data sheet.

10 Print Datasheet Prints the selected data sheet to the current
printer as set in the File | Print Setup... menu.

11 Print Workbook Prints all data sheets in the workbook to the
current printer as set in the File | Print Setup...
menu.

12 Refresh
Datasheet

Updates all copied and unlinked data on the
selected data sheet.

13 Refresh
Workbook

Updates all copied and unlinked data on all data
sheets in the workbook.

14 Start Workbook Starts data acquisition of all linked signal and
measurement sources for the entire workbook.

15 Stop Workbook Stops data acquisition of all linked signal and
measurement sources for the entire workbook.

16 Online Help Opens a dialog box to access WaveStar online
help files.

17 What’s This Help Lets you use the mouse & cursor to point at items
in the WaveStar window on which you want help.
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The Explorer View

The Explorer view graphically lists all connected instruments and
their associated parameters. There are three Explorer view categories
for each oscilloscope; Data, Setup, and Functions. The following
table describes these categories for a typical oscilloscope. However,
the actual instrument category contents depend on the connected-
instrument capabilities.

Data Instrument data sources to copy or link to data sheets.

Display Copy instrument screen to Notes data sheet or
Windows application (for example, Word).

Waveforms Instrument waveforms (such as channels and
math waveforms) to copy or link to data sheets.

Masks Instrument mask data to copy or link to data
sheets. You must copy a mask to a YT sheet to
edit the mask.

Measurements Instrument measurements (immediate, instrument-
specified measurements) to copy or link to data
sheets.

Settings Instrument settings (such as channel, time base,
display, and so on) to copy to or from the Notes
data sheet or other windows text processor. This
feature lets you save and recall instrument settings
as part of a workbook file. Refer to page 4--16 for
more information.

System System firmware and options information to copy
to a notes sheet.
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Setup Instrument control commands

Screen Copy Set screen copy parameters for the Data - Display
command.

Display Set display parameters such as format (XY, YT),
image persistence, image style (dots, vector), and
so on.

Acquire Set acquisition parameters such as mode (sample,
average, ...), sample average value, acquisition on
or off, and so on.

Vertical Set channel and math waveform vertical
parameters such as bandwidth, coupling, scale,
probe multiplier, and so on.

Horizontal Set horizontal time base parameters such as main
and delay time settings, sample record length, and
so on.

Trigger Set vertical trigger parameters such as level,
holdoff times, trigger type, and so on.

Masks Set mask source, type, enable mask display, mask
violations, pass/fail test parameters, and so on.

Measurements Set instrument measurement parameters such as
source and type of measurement.

Functions General instrument controls including run/stop, set 50%
trigger level, Autoset, and so on.
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Using The Explorer View

To display the contents of an Explorer view subtree, click on the plus
icon next to an item you want to explore. Continue clicking on plus
icons to open further subtrees. To close a subtree, click on the minus
icon next to the subtree. The lowest-level subtrees generally
represent the data or scope control that you can copy, link, or
execute.
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Copying Data from the Explorer View

Copying data results in a static snapshot of the data. The data does
not update in the application as it updates on the instrument. You can
manually refresh the data sheet by selecting the Refresh Datasheet
command in the View menu.

To copy a waveform or a scalar value into a data sheet, do these
steps:

1. Left click on the data object in the Explorer view, and hold down
the mouse button. Refer to ➀ in the following illustration.

2. Drag the data object into the data sheet and release the mouse
button. Refer to ➁ in the illustration.
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Linking Data from the Explorer View

Linking data results in dynamic data that updates in the application
as it updates on the instrument. A GPIB interface allows for faster
WaveStar data sheet updates than does the RS-232 interface: RS-232
data transfer rates are much slower than GPIB.

There are two methods of linking data to a data sheet or toolbar
button.

Linking Method 1.

1. Right click on the selected data object in the Explorer view, and
hold down the mouse button. Refer to ➀ in the following
illustration.

2. Drag the data object to target into the data sheet and release the
mouse button. Refer to ➁.

3. Click Link in the shortcut menu that pops up. Refer to ➂.
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Linking Method 2.

1. Press and hold the Ctrl+Shift keys. Refer to ➀ in the following
illustration.

2. Left click on the data object in the Explorer view, and hold down
the mouse button. Refer to ➁.

3. Drag the data object to the target. Release the mouse button and
the Ctrl+Shift keys. Refer to ➂.
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Explorer View Links, Selections, and Properties

The data and command icons also let you access further settings and
information by using a popup menu. Right-click on an icon to
display the menu.

� Show Links opens a dialog box that lists the data sheets that are
linked to this data item.

� Selections lets you select from a pop-up list of possible values.
Selecting a value sets the instrument to use that value.

� Properties opens a dialog box with a single field. The field lets
you enter parameter values directly. This field generally
duplicates the current value of the Selections menu.

� Execute causes WaveStar to execute the selected Explorer view
command.
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The WaveStar Reader

The WaveStar Reader lets you share data sheets and workbooks with
other users who do not have WaveStar for Oscilloscopes. Each user
must install the WaveStar Reader in order to open and work with
data sheets or workbooks.

You can install the WaveStar Reader from the WaveStar Software for
Oscilloscopes CD, or by downloading WaveStar Reader from the
Tektronix website (www.tektronix.com).

The WaveStar Reader operates exactly the same as WaveStar, with
the following caveats:

� Non-available commands are greyed out.

� There is no Explorer view in WaveStar Reader, as you cannot
connect or link to an instrument.

� You cannot create new data sheets in WaveStar Reader

� You can open existing data sheet and workbooks, add comments
or manipulate data, and save existing data sheets or workbooks to
the same file name or to new file names.

� You can save data sheets that were part of a workbook to
individual files. You can also save individual data sheets into a
new workbook file.

� Data sheets that were linked in WaveStar for Oscilloscopes will
not relink to the instrument. Linked data sheets show their
last-acquired data.
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Data Sheet Overview

This section of the manual describes each type of data sheet, how
and when to use them, and explains behavior common to all data
sheets.

Data Sheet Pane

The Data Sheet pane (refer to illustration on page 3--1) represents the
WaveStar workbook; the data pane is an open WaveStar workbook
that contains all data sheets that are part of the workbook file. You
can save individual data sheets without saving the workbook, or save
the workbook, which saves all data sheets within it.

Dragging a new workbook from Windows Explorer into the data
pane closes the currently open workbook and opens the workbook
you dropped onto the data pane. You are prompted to save the
currently open workbook file before it closes.

Dragging a data sheet to the data pane adds it to the open workbook.

Common Sheet Functions

All data sheets share some common characteristics. Data sheets
receive your data, waveforms, screen captures, and text, and then
display it according to the type of data sheet receiving the data. Data
sheets are used to:

� Receive data and update it if that data is linked to its source.

� Store data when saved as individual sheets or workbooks.

� Source and receive data from other data sheets.
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Creating, Opening, Saving, and Closing Data Sheets

� To create a new sheet in the open workbook, select File | New
and choose a sheet type.

� To open an existing data sheet into a workbook, drag and drop a
*.sht file from the Windows Explorer into the data sheet pane.
(Or open it from the File menu or toolbar.)

� To save a data sheet, click on its title bar in the data sheet pane,

and then click the button in the toolbar. You can also save a
data sheet by selecting File | Save Data Sheet.

� To close a data sheet, select File | Close Datasheet.

Start/Stop Data Acquisition

All data sheets contain Start and Stop acquisition tool bar buttons.
The Start button (triangle) starts data acquisition of all linked signal
and measurement sources to the selected data sheet. The Stop button
(square) stops data acquisition to the selected sheet.

� The Start and Stop acquisition buttons do not update copied or
unlinked signal or measurement data.

� If you stop a measurement that is linked to a datalog or strip
chart sheet, and then start the same measurement, WaveStar
displays a message box stating that it will discard previously-re-
corded measurements if you start recording again. You can select
to start data acquisition again, or cancel start. If you need to
continue recording data for the stopped measurement, just open a
new data sheet and link the data to the new sheet.
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Zooming

The YT, XY, and Strip Chart data sheet tool bars contain controls for
zooming the contents of the data sheet window. Zoom Full Screen
and Drag Zoom buttons are not available in the Strip Chart data
sheet.

� The percent zoom field displays the current data sheet magnifica-
tion setting, where 100% is the system-default zoom value. You
can also enter numeric values into this field by moving the cursor
into the field, clicking the right mouse button, and typing in a
new value.

Clicking on the drop-down menu arrow displays a list of
magnification values from which you can select.

� The Zoom In button (magnifying glass with a plus symbol)
zooms into the data sheet.

� The Zoom Out button (magnifying glass with a minus symbol)
zooms out from the data sheet.

� The Zoom Full Screen button is the Z with the 4-way arrow. This
button fits the graticule to the current data sheet window size,
allowing you to view the entire graticule.

� The Drag Zoom button is the Z enclosed in a box. This button
lets you select a specific sheet area to enlarge. To use, select the
Drag Zoom button, then, in the graticule, click and drag the
mouse to draw a box around the part of the waveform you want
to enlarge.
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Sizing, Tiling and Cascading Windows

� To scroll data or size the data sheet, use normal windows
procedures.

� To auto arrange or otherwise manipulate windows or icons, select
the appropriate menu items in the WaveStar Window menu.

Previewing and Printing

� To set up and preview or print data sheets, select the data sheet,
and then select File | Print. You can also print all the data sheets
that are open by selecting File | Print Workbook, and then
selecting the data sheets you want printed in the Print Workbook
dialog.

� To print the full record length of all waveforms in the YT data
sheet, select the data sheet and choose Print Banner... in the
WaveStar File menu. The Print Banner option is useful when
your YT data sheet contains waveforms that are longer than the
width of the graticule.

Copy and Linking

You can either copy or link waveform and scalar data onto a data
sheet. Copying takes a one-time snapshot of the waveform or scalar
data and places that data on a data sheet. Linking samples the
waveform or scalar data on a regular bases, constantly updating the
data sheet with the latest data.

� To copy a waveform or a scalar value into a data sheet, left click
the data object in the Explorer view and drag it into the data
sheet.

� To link, right click the data object and drag it to the target. When
you release it, choose Link from the shortcut menu that pops up.
For more detailed information, refer to page 3--15.



Data Sheet Overview

WaveStar Software User Manual 4- 5

Copying into Microsoft Office Applications

You can copy (but not link) a waveform from a data sheet into a
Microsoft Word document or Excel spreadsheet by left clicking the
data object and dragging it into an Microsoft Office application.

To copy numerical data (text) to the Windows clipboard, select
simple text or rich text in the Clipboard Formats dialog (in the Edit
menu). If you would rather copy a bit-mapped image of the data
sheet, uncheck both simple and rich text in that dialog. Then click
any measurement value and drag it to the Windows application to
which you want to copy the image.

Setting Properties

Property page settings determine the appearance and function of
each data sheet in the open workbook.

� To access the Property page for a data sheet, click in its title bar
to select it, and then choose Properties from the View menu.

You can also access Property Pages by right clicking in an active
data sheet and selecting properties from the displayed submenu.
All right-click menus for data sheets contain a Properties option,
which provides access to individual property pages.

� To navigate to individual tabbed sheets (if the property page has
multiple tabs), left click on the tab to bring it into the foreground
as needed. Click OK when you are finished entering property
settings to save the property settings, and close the dialog.

Shortcut Menu

Right click in the data sheet data area to display a pop-up menu for
performing the following tasks:

� Save, close, or print the data sheet.

� Display the property sheet for this data sheet.

� Show the data source links to the selected data sheet.

� Access the online help for the selected data sheet.
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Data Sheets and Compatible Data Types

WaveStar data sheets can handle two types of data: waveforms, such
as those displayed from an oscilloscope channel, and scalar values,
such as a volts per division or a waveform measurement.

Each sheet can accept one or more data types and will display data
differently depending on the data sheet format and source data type.

Data Compatibility Between Data Sheets

Observe the following caveats when copying or linking data between
data sheet:

� YT and XY data sheets can only accept data from YT, XY,
WaveformMeasurement, or WaveformTabular data sheets (you
must drag a complete column of data from the WaveformMea-
surement or Waveform Tabular sheet to an YT or XY sheet).

� The WaveformMeasurement sheet can source either waveform
data (if you drag a complete column of data from the Waveform-
Measurement sheet to an YT or XY sheet) or scalar data (if you
drag a single cell of data to a scalar sheet).

� Scalar-value data sheets can only accept scalar data.

� If you drag a waveform plot from the XY sheet to a YT sheet, the
plot is separated into its X and Y waveform components and
displayed as two individual waveforms.

� If you drop data onto the XY sheet, the first two available
waveforms are copied to the X and Y components. If you drop
data onto a specific component box, the data is copied to that
specific box.
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Datalog Measurements Data Sheet

A Datalog Measurement sheet periodically captures and evaluates
the value of a single scalar data item, such as a waveform measure-
ment. After evaluation, this data sheet updates its table with these
elements:

� Current Value: The current time, value, and units of the variable.

� Maximum, Minimum: The maximum and minimum values, and
the time at which each occurred.

� Average, Max-Min, Standard Deviation: Statistical values
calculated on the entire data stream. Time stamping is not
applicable.

The Datalog Measurement sheet displays each new data value as the
current value and uses each new value to continually recompute
these measurements. It does not keep previous data values (compare
with the Datalog Tabular data sheet described on page 4--9).
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I/O Operations

You use drag and drop mouse operations to copy and link scalar
values, such as a TDS oscilloscope automatic measurement, from the
Explorer View to the data logging measurement data sheet, dropping
the measurement anywhere in the data sheet table. Subsequent
copies or links to the same data sheet create separate charts (two
variables cannot be recorded in the same table).

You use drag and drop mouse operations to copy a data table from
data sheets to Microsoft Word or Excel. Two columns of scalar
values are transferred with measurement values appearing along
recording times.

You can get a screen image by dragging the entire sheet to Microsoft
Word. You can drag selected variables to Excel or another datalog
measurement sheet. Refer to page 3--15 and page 4--4.

Copying vs. Linking

You should link your data (right click and drag it), rather than
copying because copying creates a value that doesn’t update. This
data sheet monitors data, recording its variations.

Whenever the linked data changes, Explorer View notifies the sheet,
although measurements are not computed immediately. The sheet
stores the data until its display interval has elapsed, at which time
the new value is used to recompute the measurements. If no new
data has been received during the interval, the same value is used.

Starting and Stopping

The recording can be started with one of three selections: Automatic,
Manual, and Time. The default is Automatic, with a recording time
of one second. Recording can be stopped with one of three
selections: Manual, Time, or Duration. The default is Manual. You
can set the recording methods from the Recording tab of the property
page. The minimum rate is 1 second.

Property Sheet

The property sheet can set table layout and how the recording occurs
(start and stops). Refer to Setting Properties on page 4--5. Refer to
the online help for detailed information on the datalog measurement
property dialog and each control field in the dialog.
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Datalog Tabular Data Sheet

A Datalog Tabular Sheet periodically captures and enters the value
of a single scalar data item, such as a waveform measurement, in a
table.

The table displays each data point one row at a time as an entry
under the Value column. Time and Units columns record the time
stamp and the units for each data value at fixed time intervals. As
each new value is recorded, any values outside the alarm limits are
drawn in the over- or under-limit colors, and a color-coded text label
is inserted in the Out Of Limit column so that you can quickly
identify out-of-limit measurements.

Starting and Stopping

The recording can be started with one of three selections: Automatic,
Manual, and Time. The default is Automatic, with a data refresh rate
of every two seconds. Recording can be stopped with one of three
selections: Manual, Time, Duration. The default is Manual. You can
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set the recording methods from the Recording tab of the property
page (refer to Setting Properties on page 4--5). The minimum rate
you can set is 1 second.

I/O Operations

You use drag and drop mouse operations to copy and link scalar
values, such as a TDS oscilloscope automatic measurement, from the
Explorer View to the datalogging-tabular data sheet, dropping the
measurement anywhere in the data sheet table. Subsequent copies or
links to the same data sheet create separate charts (two variables
cannot be recorded in the same table).

You use drag and drop mouse operations to copy a data table from
data sheets to Microsoft Word or Excel. Two columns of scalar
values are transferred with measurement values appearing along
recording times.

You can transfer the tabular data as a screen image by dragging the
entire sheet to Microsoft Word. You can also drag selected variables
to Excel or another Datalog Tabular sheet. Refer to page 3--15 and
Copy and Linking on page 4--4.

Copying vs. Linking

You should link your data (right click and drag it), rather than
copying because copying creates values that do not update. The
Datalog Tabular data sheet monitors data, recording its variations.

When you link a scalar value to a tabular sheet, the source sends an
update whenever data changes, possibly at irregular intervals. The
data sheet collects all the data, but only enters the new row
containing a data point at the data-logging rate specified in the
data-sheet property sheet. If no new data has been received during a
data-logging interval, the data sheet retains the last value logged.

Property Sheet

The property sheet can set table layout, how recording occurs (start,
stops), and alarm limits on the recorded data. You can set these
properties from the Datalog Tabular property pages (refer to Setting
Properties on page 4--5). Refer to the online help for detailed
information on the datalogging tabular sheet property dialog box.
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Instrument Explorer Sheet

The Instrument Explorer data sheet lets you view and manipulate the
contents of instrument hard and floppy drives in an Explorer-like
window. You can also:

� Do file utility tasks (copy, delete and paste files; create and
delete directories).

� Drag and drop files from the instrument drive to a Windows
directory.

� Drag and drop instrument setups within the same instrument or to
another instrument. Some instruments do not have accessible
system settings, and so will not display this infomation in the
sheet.

� Drag and drop channel waveforms to reference waveform storage
within the same instrument or in another instrument.

� Do remote screen hardcopy operations and save the hardcopy file
to a selected location.

Tree view File view
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The Instrument Explorer sheet consists of a tree view and a file view.
The tree view (left side) shows drive directories and subdirectories in
a hierarchical tree layout, as well as instrument system files such as
saved setups and waveforms. The files view (right side) shows the
contents of a selected tree view directory.

NOTE. When you open the Instrument Explorer sheet, each
instrument actively connected to WaveStar is polled to obtain that
instrument’s drive and system information. Therefore, the more
instruments connected to WaveStar, the longer it takes to open the
Instrument Explorer sheet.

Accessing Drives and Directories

Instrument drives (hard disks or floppy drives) are represented by a
drive icon. To view the contents of a drive, select the + icon next to
that drive. The tree view displays any subdirectories that are within
the drive.

To view the files within a drive, select the drive folder icon. The file
view displays all files and directories located within the selected
folder.

Manipulating Files

To quickly copy a file to another location on the same instrument, to
a drive on another instrument, or to a Windows directory, just drag
and drop the file to the desired destination.

NOTE. You cannot drag and drop folders.

WaveStar changes the cursor icon from its default shape to a ’not’

icon ( ) if a selected file or directory cannot be moved to the

current location.

You cannot copy a reference waveform onto a waveform channel or
math source file.
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You can also right-click on a file or folder to display a pop-up menu
that contains commands to copy, delete, and paste files, as well as
directory commands that let you delete and create directories. The
pop-up menu is context-sensitive, only displaying or enabling the
commands that are available for the selected object.

The pop-up menu also contains a properties item. Selecting
properties displays a message box that contains information such as
instrument name and the path to the selected object.

System Functions

Many instruments contain internal memory locations for instrument
setups, reference waveforms, and so on. WaveStar displays these
types of memory locations under the System icon in the tree view,
and handles them like files. System categories include Hardcopies,
Setups, and Waveforms.

Hardcopies.Hardcopies lets you save the selected instrument’s screen
to a specified file. The Hardcopies file view lists the image file
formats available to your instrument. This function is a remote
screen hard copy function. To save the instrument screen image to a
file, select the Hardcopies folder in the tree view, then drag and drop
the file format type icon in the file view to the target instrument
drive or Windows directory.

Setups. Setups lists the available instrument setup locations. You use
these setup ’files’ to save the current setup to a user setup, or load a
user setup into the current instrument. To copy a current setup to a
user setup, select the current setup in the file view and drag and drop
it onto the user setup icon in the same instrument. To copy a user
setup to a current setup, select the user setup icon and drag and drop
it onto the current setup icon of the same instrument.

Waveforms.Waveforms lists the instrument waveform storage
locations, as well as the waveform sources (channels, math
operations, and so on). To copy a channel or math waveform to
waveform storage, just drag and drop the waveform source onto a
reference (Ref1, Ref2 and so on) icon.
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Notes Sheet

The Notes data sheet lets you enter and save textual notes and
graphical images that you want to record for the open workbook file.
Specifically, you can do the following:

� Type textual notes.

� Copy and paste notes and bitmapped images between the
clipboard and the notes sheet.

� Drag and drop instrument screens from the Explorer View to the
notes sheet.

� Drag and drop (or cut, copy, and paste, depending on application)
between the notes sheet and other Windows applications.

� Save, recall, and edit instrument setup information in a Notes
sheet or other ASCII text editor.

� Right click in the data sheet area to pop-up a menu that lets you
save, close, or print your data sheet or access online help about
the data sheet.

� Format the text font, color, and alignment using the toolbar
buttons. (If the toolbar buttons for the Notes Sheet are not
displayed, go to the View menu for the WaveStar application and
check Datasheet Toolbar.)

� Use toolbar buttons and WaveStar menu commands to Save, Cut,
Copy, Paste, and Print notes sheet contents.
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Supported Applications

Use your mouse to drag and drop text or bitmapped images between
the notes sheet and Windows applications such as Microsoft Office
applications and the Windows Notepad.

When copying an XY or YT graticule to another application, you
have the choice of copying the graticule as it is displayed on screen
(which may be a partial graticule) or copying the entire graticule.
Copying a partial graticule is useful if, for example, you want to
zoom in the display and copy a particular area of a waveform. To
always copy the entire graticule whether or not it is fully displayed,
select the View menu and check the Transfer Full Graticule menu
item.



Data Sheet Overview

4- 16 WaveStar Software User Manual

Saving and Recalling Instrument Settings

WaveStar lets you save, recall, and edit instrument settings in the
Notes data sheet. You can save settings for the entire instrument or
specify a category of settings such as trigger or horizontal. The
settings are stored as one long ASCII string of instrument-specific
programming commands.

To save the current instrument settings, select Data | Settings in the
Explorer view. Then use the mouse to drag and drop the setting
information to save from the Explorer view to the Notes sheet.

To recall settings to load into an instrument, open the Notes sheet
that contains the settings to load. Next, select the instrument setting
text with the mouse. Make sure you do not forget any text critical to
command syntax, such as colons or semicolons. Finally, drag and
drop the selected text onto the appropriate Data | Settings icon in the
Explorer view.

If you are familiar with the programming commands for your
instrument, you can edit the commands in the Notes sheet to change
your instrument settings. Use the standard windows commands and
methods to enter, copy, cut, and paste text in the Notes sheet.
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Power Harmonics Data Sheet

The Power Harmonics data sheet displays power and harmonic
information based on signal voltage and current waveforms. You can
display the power and harmonic information in either table or
graphical bar chart format. The following figures show the same
power harmonics data in tabular and graphical format.
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Power Harmonics Conventions. The following conventions apply to the
Power Harmonics data sheet:

� You need to provide both a voltage and current waveform.

� You can copy or link voltage and current information from an
instrument in the Explorer view or from another data sheet.

� For optimum harmonics calculations, use four signal cycles.
Fewer cycles will result in less accurate calculations, and more
cycles does not improve calculation accuracy. The status bar at
the bottom of the sheet displays an error message when fewer
than four cycles are used for calculations.
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Once both waveforms are copied or linked, the Power Harmonics
sheet calculates the power waveform by multiplying the voltage and
current waveforms. You can copy or link the calculated power
waveform to another data sheet. WaveStar recalculates and updates
power and harmonic information whenever the data changes (when
linked) or a refresh action occurs.

Power Harmonics Sheet Fields

The following text describes the purpose of each Power Harmonics
sheet field.

View. Selects between viewing data in graphical mode or tabular
mode.

Nmbr Harmonics. Selects the number of harmonics to use for
calculating harmonic information. The range of values is from
2 to 51.

Type (graph view mode). Selects which data type to display in the bar
graph area. Available types are voltage RMS, voltage % of
fundamental, voltage phase, current RMS, current % of fundamental,
and current phase.
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Waveform fields. Location where you drag source voltage and current
waveforms, and location of calculated power waveform that you can
drop onto another data sheet or instrument. The highlighted portions
of waveforms in the fields are the cycles used for calculating power
harmonics information.

Trigger Adjustments.Aligns the voltage and current waveform trigger
points. The Power Harmonics sheet calculates power by aligning the
voltage and current waveforms trigger points. Because you can use
different instruments to measure voltage and current values, you may
need to align waveform trigger points. You can let WaveStar use the
waveform trigger points as is (automatic mode), or adjust the trigger
point for either or both the voltage or current waveforms (manual
mode).

Cycle Width. Sets the mimimum cycle width over which the sheet
calculates power harmonic information. You can let WaveStar
automatically determine the mimimum cycle width, or set this field
to manual and adjust the minimum cycle width to meet your
requirements. Noisy signals may require you to manually select a
longer cycle width.

The Power Harmonics sheet shows which cycles are used for
calculations by highlighting the waveform cycles in the Waveform
fields.
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Scalar-Viewer Data Sheet

If you want to view one or more scalar values, copy or link them
from the Explorer view to this data sheet. Such values display with
time stamp, data value, and data units.

When you want to compile a custom view of measurements (or any
set of scalar data) or download your TX-DMM stored memory
(WSTRM), use the Scalar-Viewer. For example, if you want to
continuously monitor measurements taken by different instruments,
connect those instruments to WaveStar and drag those measurements
from the Explorer View to a common Scalar-Viewer sheet. Or drag
scalars from other data sheets to the Scalar-Viewer sheet.

I/O Operations

You use drag-and-drop mouse operations to copy and link scalar
values, such as a TDS oscilloscope automatic measurement, from the
WaveStar Explorer View to the Scalar-Viewer sheet, dropping the
waveform anywhere in the data sheet table. Subsequent copies to the
same Scalar-Viewer sheet create separate rows in its table.

Copy your data if you want to just get the current value; link it (right
click and drag it), if you want the data to update.

You use the same operations to copy and link scalar values from
Scalar-Viewer data sheets to other data sheets that accept scalar
values. Refer to page 3--15 and Copy and Linking on page 4--4.
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Supported Applications

You use drag-and-drop mouse operations to copy a Scalar-Viewer
table to data sheets or to Microsoft Word or Excel. Scalar values are
transferred with measurement values appearing alongside recording
times.

To copy a bitmapped image of the data sheet instead of numerical
values, uncheck both simple and rich text in Clipboard Formats
dialog box, accessed from the Edit menu, before copying.

Property Sheet

The property sheet can set various attributes of the table layout. You
can set these attributes from the Scalar-Viewer properties page (refer
to Setting Properties on page 4--5). Refer to the online help for a
detailed description of the Scalar-Viewer data sheet property page
and each entry field in the property sheet.

StripChart Data Sheet

A StripChart data sheet plots the value of from 1 to 16 single scalar
data items, such as a waveform measurement, on a scrolling
horizontal graticule. Although you can monitor up to 16 values in a
StripChart data sheet, for practical reasons you will probably not
want to measure more than two or three variables per data sheet.

The StripChart data sheet contains two windows; the current data
window, and the history data window. The current data window
shows the current data for the last n time periods, where n is defined
by the acquisition sample rate. New data ’pushes’ old data to the left
edge of the graticule, and data at the left edge of the current data
window is erased from the graticule. You can choose to have points
on the graph connected by lines or displayed as levels (dots).
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History data
window

Current data
window

The history data window displays all data points acquired from the
start of the current acquisition. To view the history window, move
the cursor onto the vertical window separator bar at the left of the
current data window, press and hold the left mouse button, and drag
the separator bar to the right. You can then use the scroll bar controls
to view entries in the entire history data window. By default, the
history data window is minimized when you first open a StripChart
data sheet.
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I/O Operations

You use drag and drop mouse operations to copy and link scalar
values, such as a TDS oscilloscope automatic measurement, from the
Explorer View to the StripChart data sheet, dropping the measure-
ment anywhere in the graticule area. Subsequent copies to the same
StripChart sheet create separate strip chart graticules within the
StripChart window (two measurements cannot be plotted on the
same StripChart graticule). You cannot drag waveforms from a YT
or XY sheet to a StripChart sheet.

You use drag and drop mouse operations to copy a StripChart
recording to data sheets or Microsoft Word or Excel. Two columns
of scalar values are transferred with measurement values appearing
along recording times. Refer to page 3--15 and Copy and Linking on
page 4--4.

Copying vs. Linking

Strip charts monitor data, recording its variations. Because of this,
you should link your data rather than copying it, since copying
creates a value that does not update. To link data, right click on the
data and hold down the mouse button; drag the data to the Strip chart
sheet. Then select Link from the shortcut menu that pops up.

When you link a scalar value to a Strip chart sheet, the data source
sends updated data whenever data changes, possibly at irregular
intervals. The data sheet collects all the data, but only plots a data
point at the plot rate specified in the strip-chart property sheet. If no
new data has been received during a data-logging interval, the data
sheet plots the last value logged.

Starting and Stopping

The recording can be started with one of three selections: Automatic,
Manual, and Time. The default is Automatic, with a recording
sample time of one second. Recording can be stopped with one of
three selections: Manual, Time, or Duration. The default is Manual.
You can set the recording methods from the Recording tab of the
property page (refer to Setting Properties on page 4--5). The
minimum data sample rate you can set in the properties page is
1 second.
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NOTE. If you restart recording on a stopped sheet, all data in that
data sheet is lost. To save data, open a new data sheet and link to the
same sources as the stopped sheet.

Property Sheet

The property sheet can set a variety of display characteristics, turn
on various types of measurement cursors, and more. You can set
these properties from the Strip Chart properties pages (refer to
Setting Properties on page 4--5). Refer to the online help for
detailed information on the StripChart property dialog and each
control field in the dialog.

Cursors

Cursors are used to measure the waveform plot. You can put cursors
on the strip-chart sheet using the Cursor Property Page. Cursor
readout values indicate the vertical or horizontal value at the cursor
location. Vertical cursor position values appear as dX and X.
Horizontal cursor position values appear as dY and Y.

Vertical and horizontal are the only permitted cursor types on the
Stripchart sheet.

Waveform Measurement Data Sheet

The waveform measurement data sheet displays a table of standard
waveform measurements. When you drag a waveform to this sheet,
the application automatically calculates and displays the measure-
ment values as shown below in the following figure.

Each waveform is presented as a column of measurements. Each
time a new waveform is dropped onto this sheet, a new column of
measurements is created immediately to the right of any existing
columns.

I/O Operations

You use drag and drop mouse operations to copy and link waveforms
(not scalar data) from the Explorer View to the waveform measure-
ment data sheet.
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You use the same operations to copy and link waveforms from this
data sheet to other data sheets. You can also copy or link a single
measurement from this data sheet to any other sheet that accepts
scalar values. Refer to page 3--15 and Copy and Linking on
page 4--4.



Data Sheet Overview

WaveStar Software User Manual 4- 27

Supported Applications

You use drag and drop mouse operations to copy measurements from
this sheet to Microsoft Word or Excel. Specifically, you can do the
following:

� Click a single measurement and drag it to Microsoft Word or
Excel.

� Shift click to select more than one measurement for dragging as a
group.

� Click in the title bar to select all of the measurements; shift click
to select additional columns as desired. After selecting the last
column, hold shift to drag all the columns to Word or Excel.

Property Sheet

Use this property sheet to control table layout characteristics and the
measurement method (refer to Setting Properties on page 4--5).
Refer to the online help for detailed information on the waveform
measurement property dialog and each control field in the dialog.

Waveform Tabular Data Sheet

A Waveform Tabular Sheet creates a table of values for each
waveform that you copy or link to it. It periodically updates the
values if you link them from the data source.

The Waveform Tabular Sheet shows the waveform as sequential
values in a table column with each value accompanied by a time
value. The time value is the time of the waveform sample relative to
the waveform record trigger.

You can modify the waveform by editing the table cells, but you can
not change the length of the waveform by adding or deleting cells,
nor can you change the units.
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I/O Operations

You use drag and drop mouse operations to copy and link wave-
forms, such as channel waveforms from a TDS oscilloscope, from
the Explorer View to the waveform-tabular data sheet, dropping the
waveform anywhere in the data sheet table. Subsequent copies or
links to the same data sheet create separate table charts (two
waveforms cannot be recorded in the same table). You must drag a
complete waveform (a column) to an XY or YT data sheet (or
another Waveform Tabular data sheet).
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Use drag and drop mouse operations to copy a table from a data
sheet to a Microsoft Office application. Two columns of scalar
values are transferred with measurement values appearing along
recording times.

You can transfer the tabular data as a screen image by dragging the
entire sheet to Microsoft Word. You can also drag selected variables
to Excel or another Datalog Tabular sheet. Refer to page 3--15 and
Copy and Linking on page 4--4.

Property Sheet

Use this property sheet to control table layout characteristics (refer to
Setting Properties on page 4--5). Refer to the online help for
detailed information on the waveform tabular property dialog and
each control field in the dialog.
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XY Data Sheet

The XY sheet displays waveforms in pairs as XY plots, with one
waveform plotted on the X (horizontal) axis against the other on the
Y (vertical) axis. The XY plot uses the same scale and position as
the oscilloscope channels from which the XY components are
obtained.

The XY sheet presents the XY plot as a pair of X and Y component
boxes, which appear along the bottom of the graticule.

I/O Operations

Using the mouse to copy and link waveforms from the Explorer
View to the XY data sheet, you can do the following I/O operations:

� Drag individual channel waveforms from the Explorer View and
other data sheets to the individual X or Y component boxes
(located just below the bottom graticule) that comprise each XY
waveform.
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� Drag two instrument waveforms simultaneously to an XY sheet
by dragging the instrument icon from the Explorer View and
dropping the icon anywhere on the XY graticule. The first
waveform in the hierarchy is plotted as X, the second as Y.

� Drag from each X and Y component individually, to the Explorer
View or another data sheet. To restore the waveform as a saved
waveform for an instrument, display the instrument reference
memories, and drag the waveform to the memory that is to store
the waveform. You cannot undo this operation.

� Drag and drop X and Y components individually or as an XY
waveform into Microsoft Office applications.

When copying an XY graticule to another application, you have the
choice of copying the graticule as it is displayed on screen (which
may be a partial graticule display) or copying the entire graticule.

Copying a partial graticule is useful if, for example, you want to
zoom in the display and copy a particular area of a waveform. To
always copy the entire graticule, select the View menu and check the
Transfer Full Graticule menu item.

You can drop data onto either the XY sheet or to a specific
waveform component box. Data dropped onto the XY sheet uses the
first two waveforms as the X and Y components. Data dropped onto
a specific waveform box overwrites existing data. The XY plot is
drawn when both the X and Y component boxes are filled in.

Property Sheet

The property sheet can set various display and measurement
characteristics. You can set these properties from the XY Properties
page (refer to Setting Properties on page 4--5). Refer to the online
help for detailed information on the XY sheet property dialog and
each control field in the dialog.

Cursors

Cursors are used to measure the waveform plot. You display cursors
using the Cursor tab on the Property Page. Cursor readout values
indicate the vertical or horizontal value at the cursor location.
Vertical cursor position values appear as dX and X. Horizontal cursor
position values appear as dY and Y.
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YT Data Sheet

The YT data sheet lets you capture and graphically view multiple
waveforms on a graticule with the same scale and position as on the
oscilloscope. You also use the YT sheet to copy and edit waveform
test masks. The YT sheet can display waveform and mask data
simultaneously, enabling you to create a mask to fit a particular
waveform.

Waveform Operations

The YT sheet displays one or more waveforms as a graphical view.
This sheet displays amplitude on the Y-axis and the sampling index
(for example, time) on the X-axis. The YT sheet displays waveforms
and a graticule at the same scale and position as they appear on the
oscilloscope screen. The number of waveforms that can be displayed
is limited only by available memory. Some of the features of this
sheet include cursor measurements, zoom function, and annotation.
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Copying Waveforms To and From an Instrument.

You use drag and drop mouse operations to copy and link waveforms
from the Explorer View to the YT data sheet, dropping the waveform
anywhere in the graticule area. You also use drag and drop mouse
operations to copy data from data sheets to other Microsoft Windows
applications. When copying a YT graticule to another application,
you have the choice of copying the graticule as it is displayed on
screen (which may be a partial graticule) or copying the entire
graticule.

Copying a partial graticule is useful if, for example, you want to
zoom in the display and copy a particular area of a waveform. To
always copy the entire graticule whether or not it is fully displayed,
select the View menu and check the Transfer Full Graticule menu
item.

To restore the waveform to a specific channel, expand the instrument
data channels in Explorer View, and drag the waveform to the
desired channel. You cannot undo this operation. Refer to page 3--15
and Copy and Linking on page 4--4 for more information.

Changing the Waveform Scale. The Scale pulldown lists (located to the
left of the Waveform button) in the sheet toolbar let you change the
voltage or time scale of the selected waveform. To change a
waveform’s scale, select a waveform, then select the arrow button
adjacent to the scale value to change. Select a new scale value from
the pulldown list. The YT sheet redraws the selected waveform using
the new scale value.

Selecting the Waveform Color. The Waveform button in the sheet
toolbar lets you change the color of the selected waveform. To
change a waveform color, select a waveform, then select the
Waveform button. Select a new waveform color, then select OK.

Property Sheet. The property sheet can set various display and
measurement characteristics. You can set these properties from the
YT Properties page (refer to Setting Properties on page 4--5). Refer
to the online help for detailed information on the YT sheet property
dialog and each control field in the dialog.
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Cursors. Cursors are used to measure the waveform plot. You can put
cursors on the selected sheet using the Cursor tab on the Property
Page. Cursor readout values indicate the vertical or horizontal value
at the cursor location. Vertical cursor position values appear as dX
and X. Horizontal cursor position values appear as dY and Y.

Print Banner

To print the full record length of all waveforms in the YT data sheet,
select the data sheet and choose Print Banner... in the WaveStar File
menu. The Print Banner option is useful when your YT data sheet
contains waveforms that are longer than the width of the graticule.

Mask Editing

The YT sheet mask editing features allow you to create new test
masks for an instrument family by modifying existing masks or
defining mask parameters from scratch. The copied mask retains the
instrument settings that were part of the original mask.

To edit an existing mask, or create a new mask based on an existing
mask, simply drag and drop a mask from the Explorer view onto the
YT sheet. WaveStar draws the mask on the graticule and shows
existing line vertexes (points) as small squares, as shown in the
following figure.

NOTE. If a mask is visible on your YT sheet, and you copy or link the
YT sheet to another data sheet, the mask data is copied along with
the waveform data. To prevent this, clear the Show Mask checkbox in
the toolbar before copying or linking the YT sheet data to other
sheets.
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Mask Editing Conventions. The following conventions apply to the YT
mask editing functions:

� Copying a new mask onto a YT sheet with an existing mask
deletes the existing mask and replaces it with the new mask.

� This documentation refers to each polygon in a mask as a
segment, and a collection of segments as a mask. However, some
instrument documentation calls each segment a mask, as well as
the collection of segments.

� Each CSA-Series mask can contain a maximum of ten segments:
Each TDS-Series mask can contain a maximum of eight
segments.

� Each mask segment can have a maximum of 50 points.

� The YT sheet connects mask points in the same order that the
mask source instrument connects those points. As different
instruments use different algorithms to store and connect mask
segment points, copying a mask from one instrument series to
another may change the mask point order, and therefore change
the mask segment shape.

� To select a mask point or segment, position the cursor on the
point or in the segment and double--click the left mouse button.
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Selecting Mask Color. The Mask button in the sheet toolbar lets you
change the color of the mask outline. To change the mask outline
color, select the Mask button, select a new mask color, then select
OK. The new mask color is stored and automatically used for all new
YT sheets you open.

The mask color only affects the YT sheet mask color; the instrument
will use its default mask color when you copy the YT mask to an
instrument.

Show Mask.You use the Show Mask check box to toggle viewing of
the mask on the YT sheet.

Show Bounding Box.You use the bounding box mode to quickly resize
a mask segment. Bounding box mode displays a box around each
segment that includes resizing points on the corners and sides of the
bounding box. When you select and drag a resizing point, the
bounding box redraws the mask segment proportionally to fill the
resized bounding box. You cannot move any individual segment
points while you are in bounding box mode.
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Moving Mask Segment Points. To select a segment point, position the
cursor on the point A selected point fills with the current mask color.
To move the point, press and hold the left mouse button and drag the
point to a new location.

You can use the Zoom control on the YT sheet toolbar to magnify
the image for performing critical point positioning. The point
position values are shown in the status bar at the bottom of the sheet.

NOTE. As stated in the mask edit conventions section, different
instruments use different algorithms to store and connect mask
points. In some instruments, moving a point past a diagonal
boundary causes that point to detach from its current line and
reattach to a line on the other side of the boundary. This is normal
behavior for these instruments. The YT sheet duplicates this behavior
so that the mask segments you create on the YT sheet will look and
work correctly on the target instrument.

Adding and Deleting Mask Points. The Mask editor lets you add new
points to a segment halfway between the selected point and the next
point counterclockwise from the selected point. To add a point,
select the point, then press the right mouse button to display the
pop-up menu. Select Add Point. The YT sheet adds the new point to
the line segment.
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To delete a point, select a point, click the right mouse button, and
select Delete Point from the pop-up menu.

Adding, Duplicating, and Deleting Mask Segments. To add a new segment
to a mask, select Mask > Add Segment from the WaveStar main
menu. WaveStar adds a small box segment to the upper-left corner of
the graticule, and assigns it the next consecutive mask segment
number. You can then edit this new segment by adding and moving
points to obtain the mask segment shape you need.

To duplicate a segment, position the cursor within the segment; the
cursor will change to a four-way arrow to indicate that you are
within a segment. Then right-click the mouse to display the pop-up
menu. Select Duplicate; WaveStar draws the duplicated segment
slightly above and to the right of the selected segment.
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To delete a mask segment, position the cursor within the segment,
right-click the mouse, and select Delete Segment from the pop-up
menu. WaveStar deletes the selected mask segment. You can also
delete the entire mask by selecting Delete Mask from the pop-up
menu.

The Change Size... pop-up menu item opens a dialog box that lets
you enter numeric parameters to increase or decrease the size of a
segment.

Mask Table Editing.Another way to move points is to use the mask
point table. The point table lists all points in a segment with their
corresponding position. To display the point table, select a segment
and right-click the mouse button to display the segment pop-up
menu. Select Tabular View... ; WaveStar displays the Mask Tabular
View dialog box.

To edit the values in the dialog box, position the cursor in the table
cell to edit, then left-click the mouse. Enter the new value for the
cell. Repeat for each cell to edit. The mask segment updates
immediately when you enter new values in the table.
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� To add a new point to the table, select a row and then press the
INSERT keyboard key. The table editor inserts a new blank row
above the selected row.

� To add a new point to the end of the table, select the last row in
the table and then press the ENTER keyboard key.

� To delete a point from the table, select the point row to delete
and press the DELETE keyboard key.

� To edit a different segment, select a new segment from the
Segment Identifier pulldown list.

� When you are done editing the table cells, select the Close
button.

� To change the units used to display the point positions, select the
Units list to select between Amplitude/Time and Divisions. The
table values update to show the selected unit type.

Creating a New Mask. You can use WaveStar to create new masks
from scratch. To create a new mask, open a new YT data sheet. Then
select Masks > New Mask. Next, select the target instrument family
for the mask from the Select Instrument dialog box. WaveStar draws
a square segment in the center of the YT graticule. Finally, use the
mask edit functions to create the segments for your new mask.
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To set the mask parameters, open the Edit Mask Parameters dialog
box (Masks > Tabular View > Edit Parameters...). The number
and type of parameters displayed depends on the parameters
supported by the target oscilloscope. Refer to oscilloscope
documentation for a description of that instrument’s mask parame-
ters.

Saving a Mask.WaveStar handles a YT sheet with a mask just like any
other data sheet file; you can save the YT sheet as part of a
workbook, or you can save the YT sheet to an individual file. You
can create a mask library by creating a workbook that contains only
YT sheets with mask data. You can also save mask data by exporting
it to a .MSK format file. Refer to page 4--42 for information on how
to import and export .MSK files.

Copying a Mask to an Instrument.When you are ready to load your
mask on an instrument, position the cursor within the graticule but
outside of any mask segments. Press and hold the left mouse button,
and move the cursor to the appropriate icon in the Explorer view.
WaveStar loads the mask data into the instrument.
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Importing/Exporting a Mask.WaveStar can import and export MSK
mask format files. To import a MSK file, select File > Import...,
select Mask Files Type, and navigate to the mask file to import.
WaveStar loads the mask data into the active YT data sheet.

For your convenience, WaveStar comes with library of mask files in
.MSK format. The mask library is located in the WaveStar
installation directory, in a directory called MaskLibrary. The mask
files are organized by instrument family and measurement type.

To export the mask in the active YT sheet to a .MSK file, select
File > Export Datasheet..., and then enter the file name and
destination directory.
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Procedures

This section outlines task--oriented procedures for using WaveStar
Software.

Display Waveforms in the YT Data Sheet

Follow the steps below to display waveforms in the YT view.

1. In the Explorer View, click on the Data branch under the
instrument that will source the waveform to display the data
resources under it.

2. Double click on the Waveforms resource (or single click its +) to
display the waveform sources below it.

3. To copy, left click and drag the waveform resource (Channel,
Math, or Ref) to the YT data. Release the waveform in the data
sheet graticule area to drop the waveform on the data sheet.

4. To link rather than copy, right click and drag the waveform to the
YT data sheet. Release the mouse button, and select Link in the
shortcut menu that pops up.

5. Repeat this procedure to copy or link additional waveforms to the
data sheet as desired.

Tips

� Drag the channel indicator (located left of the graticule) up and
down to vertically position the waveform. (You can also use the
keyboard arrows (↑ and ↓) to position the waveform.)

� Drag the waveform record view (located above the graticule) to
horizontally position the waveform in the graticule. (You can also
use the keyboard arrows (← and →) to position the waveform.)

� To remove the waveform just dropped into the window,
immediately select Undo Drop Waveforms in the Edit menu (the
undo function is not available for extremely large records).
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Display Two Waveforms in the XY Data Sheet

Follow the steps below to display waveforms in the XY view.

1. In the Explorer View tree, click on the Data branch under the
instrument that will source one of the waveforms to display the
Data resources under that Data branch.

2. Double click on the Waveform resource (or single click its +) to
display the waveform sources below it.

3. To copy, left click and drag the waveform source (Channel, Math,
or Ref) onto the X tab. Release the waveform while holding it
over the X tab.

To link rather than copy, right click and drag the waveform to the
X tab. Release the mouse button, and select Link in the shortcut
menu that pops up.

4. Repeat this procedure to display a Y source and copy or link it to
the Y tab. Be sure to release over the Y tab, not the X tab.

NOTE. The X and Y tabs always appear below the graticule. If they
are not visible, expand or scroll the data sheet window.

Tips

� If you drag and drop a data source icon that contains more than
two waveforms onto the XY graticule, the first waveform in the
list will be used for the X tab and the second available waveform
will be used for the Y tab.

� Drag the indicator to the left of the graticule up and down (or use
the keyboard ↑ and ↓ arrows) to vertically position the XY plot
to position the waveform.

� Drag the indicator above the graticule to horizontally position the
XY plot.
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� To swap the X waveform with the Y, select Swap XY from the
Edit menu.

� To remove a waveform just dropped into the window, immediate-
ly select Undo Drop Waveforms in the Edit menu.

Dynamically Position Waveforms

1. In an XY or YT data sheet, locate the channel indicator of the
waveform to be positioned. YT sheets have channel indicators on
the left border of the graticule; XY sheets have a Y channel
indicator on the left border and an X channel indicator on the top
border of the graticule.

2. Click and drag any of the channel indicators to adjust positions as
desired up and down (and left and right for XY data sheets).

3. YT waveforms have a waveform record view above the graticule.
Click and drag the record view to position the selected waveform
horizontally in the graticule.

Zoom the YT, XY, or StripChart Data Sheets

In YT, XY, or StripChart data sheets, use the following methods for
zooming in or out.

To Zoom in Increments or by %

Click the first toolbar button from the left to zoom in; click the
second toolbar button to zoom out.

Select a percentage to zoom to from the drop-down list on the data
sheet toolbar. The display will zoom to a percent of the default full
size.

To Zoom to Full Screen (YT and XY sheets only)

Click the third toolbar button to zoom the data sheet display to best
fit the current size of the graticule to the data sheet window.
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To Zoom On a Waveform Feature (YT and XY sheets only)

Click the fourth toolbar button to begin to zoom in on a waveform
feature. Left click and drag to draw a zoom box around the feature to
be viewed. Release the left mouse button to complete the zooming.

Change the YT or XY Waveform Display (Properties)

To change the position and scale of a waveform in a YT or XY data
sheet, first open a YT or XY data sheet, and drag waveform data
from the Explorer View into the data sheet.

To Position a Waveform

For data in both YT and XY data sheets, drag the channel indicator
(left of graticule) up and down to vertically position the waveform.

For data in an YT data sheet, drag the waveform record view (above
graticule) to horizontally position the selected waveform in the
graticule.

To Scale a Waveform

1. Select View > Properties.

2. Select the Graticule tab in the Properties dialog and set the
number and size of the horizontal and vertical divisions.

3. Select the desired waveform tab in the Properties dialog; use the
pulldown lists to select the horizontal and vertical scale and
position settings of the waveform.

4. Click OK to apply the changes and close the Properties dialog.

To Change Waveform Color

To change the color of a waveform after the waveform has been
acquired, follow the steps below.

1. While in the XY or YT data sheet, select View > Properties.

2. When the Waveform Properties dialog window appears, select
the tab containing the name of the desired waveform, click the
color button, select a new color from the Color window, and click
OK to accept the color change and close the dialog.
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3. Click OK in the Waveform Properties dialog window.

To Lock the Trigger Points or Horizontal Scales of YT Waveforms

1. With the YT data sheet selected, select View > Properties.

2. Select the Plot tab in the Properties dialog.

3. Select or deselect the check boxes to toggle locked trigger points
and horizontal scales.

4. Click OK to accept the changes and close the Properties dialog.

To Display the Trigger Point on YT Waveforms

1. With the YT data sheet selected, select View > Properties.

2. Select the Plot tab in the Properties dialog.

3. Select or deselect the Display Trigger Point checkbox to toggle
the trigger point display on the graticule.

4. Click OK to accept the changes and close the Properties dialog.

To Change the Graticule for XY and YT Data Sheets

1. With either an XY or YT sheet selected, select View > Proper-

ties.

2. Select the Graticule tab in the Properties dialog. In this dialog
you can set the following Graticule properties:

Graticule Type. Select from Full, Grid, Crosshairs, or Frame.

Horizontal Divisions. Set the number of horizontal divisions.

Vertical Divisions. Set the number of vertical divisions.

Size of Divisions. Set the size and dimensions of the horizontal
and vertical divisions.

Graticule Color. Set the graticule color.
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Background Color. Set the graticule background color.

Print black and white. Toggles the printing color of the data
sheet.

Set Default. Click Set Default to set the new settings as default.

3. Click OK to accept the changes and close the Properties dialog.

To Change the Plot Style of XY Waveforms

1. With the XY data sheet selected, select View > Properties.

2. Select the Plot tab in the Properties dialog.

3. In the Plot Type pulldown list, select either Dots or Vectors for
the plot type. Dots displays the waveform data points as
individual dots on the graticule. Vectors displays the waveform
data points as a connected line on the graticule.

4. Click OK to accept the changes and close the Properties dialog.

Creating a New Mask

1. Open a new YT data sheet.

2. Select Masks > New Mask.

3. Select the target instrument family for the mask from the Select
Instrument dialog box.

4. Use the mask edit functions to create and edit the segments for
your new mask.

5. Select Tabular View from the Masks menu.

6. Select the Edit Parameters... button.

7. Enter the mask parameters in the Edit Mask Parameters dialog
box.

8. Click OK to accept the mask parameters.

9. Save the YT sheet.
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Measure Waveforms using the Waveform Measurement
Data Sheet

Drag and drop waveform data from YT, XY, or Waveform Tabular sheet
into Waveform Measurement sheet

1. Open a YT, XY, or Waveform Tabular sheet with waveform data
in it.

2. Select File > New.

3. Select Waveform Measurement Sheet from the New Sheet
dialog.

4. Use the mouse to drag the waveform (from the XY or YT sheet)
or column of waveform data (from the waveform tabular sheet)
to the waveform measurement data sheet. The waveform
measurement data sheet will update with measurement values of
the waveform data you dragged to it.

Measure StripChart Plots using Cursors

1. Select File >New, and select StripChart from the New Sheet
dialog to open a StripChart data sheet.

2. With the StripChart sheet selected, select View > Properties.

3. Select the Cursors tab in the Properties dialog, and select a
cursor type from the pulldown list. Click OK to apply the new
settings and close the dialog.

4. Use the mouse to set the cursor positions in the StripChart data
sheet.

Set Up Instrument (Data Source)

1. Make sure the GPIB or RS-232 connection from the PC to the
instrument is established.

2. With a GPIB or RS-232 connection between the PC and the
instrument established, instrument resources, including most
control settings, automatically appear in the Explorer view.
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3. In the Explorer view, click on the Setup branch under the
instrument to be adjusted to expand the instrument setup
properties under it.

4. Click the control to be adjusted, and then right click to pop up its
shortcut menu.

5. If the shortcut menu entry Selections is not disabled (grayed out),
point to it to expand the available selections. If the shortcut menu
entry Selections is disabled, select Properties in the menu instead.

6. Click on the control setting of your choice to complete setting up
the control.

7. In the Properties dialog box, type in a valid value (for example,
200 mV for CH 1 volts).

8. Press OK to apply your selections; press Cancel to discard them.
Both buttons close the Properties dialog box.

Copy the Instrument Screen

To copy an instrument-screen image to a Notes sheet:

1. Select File > New. The New data sheet dialog box appears
displaying a list of available data sheets from which to select.

2. Select Notes Sheet, and click OK.

3. In the Explorer view, click to first expand the list of connected
instruments, and then click the instrument whose screen you
intend to copy.

4. Click Display in the instrument resources to access the Screen
Copy icon.

5. Left click and drag the Screen Copy icon to the Notes sheet and
drop it. The instrument screen appears in the Notes sheet.



Procedures

WaveStar Software User Manual 5- 9

Copy the Screen Image to a PC Application

1. Click the title bar of the Notes sheet that contains the bitmap
image you want to copy.

2. Click on the bitmap image.

3. Select Edit > Copy.

4. Display the application to receive the bitmap image and paste the
image using the application menus (usually the Edit menu).

Restore a Waveform to an Instrument

After acquiring a waveform, follow the steps below to restore that
waveform back to an oscilloscope that supports reference wave-
forms. This way the instrument can operate on the stored waveform
(displaying and using the waveform in Math functions, if supported).

1. In the Explorer view, click to expand the Setup branch under the
instrument to which the waveform is to be restored. This step
displays the reference location that will receive the waveform.

2. Turn on the reference location on the instrument.

3. Click and drag the waveform from a YT sheet (or the data
column in tabular sheets) to the reference location in the Explorer
view that you displayed in step 1.

If you are restoring a waveform from one instrument back to a
different instrument, you need only to drag the waveform and
drop it on the new instrument icon in the Explorer view.

4. Release to drop the waveform and store it in the instrument
reference location.

Install/Uninstall

See Installing and Running WaveStar beginning on page 1--5 for
installation and uninstallation procedures.
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Connect to Instrument (GPIB & RS-232)

Verify that your PC GPIB board and software is installed according
to the manufacturers instructions. Then see Setting Up PC to
Instrument Communications on page 1--5.

Saving and Restoring Data Sheets

Follow the steps below to save and restore a data sheet to the current
workbook:

Save a Data Sheet

1. Select the title of the data sheet you want to save to make that
sheet active and bring it to the front of any other data sheets that
are also open.

2. Use one of the following methods for displaying the Save dialog:

� Select File > Save Data Sheet.

� Click the Save Data Sheet button in the toolbar.

� Right click in the data sheet area, and select Save Data Sheet

from the shortcut menu that pops up.

3. In the Save dialog, enter a file name and destination for the data
sheet. Data sheet files have a .SHT extension.

4. Click OK to save the data sheet and close the dialog.

Restore a Data Sheet

1. Open the workbook file in which you will restore the data sheet.

2. Use one of the following methods for restoring the data sheet to a
workbook:

� Select File > Open and select the data sheet file you want to
restore. Click OK.

� Drag the data sheet file from Windows Explorer View and
drop it on the data pane.

3. The Reconnect Links dialog appears, prompting you to select
Reconnect or Offline.
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Reconnect. Select Reconnect to reconnect the links used when
the data sheet was last saved.

Offline. Select Offline to open the data sheet without restoring
the links to the original data sources.

NOTE. If you select Reconnect and the data source is no longer
available, a dialog will appear, and the data sheet will be opened as
an offline file (no active links).

Saving and Restoring Workbooks

Follow the steps below to save and restore a workbook:

Save a Workbook

1. Use one of the following methods for displaying the Save dialog:

� Select File > Save Workbook.

� Click the Save Workbook button in the toolbar.

2. In the Save dialog, enter a file name and destination for the
workbook. Workbook files have a .WK extension.

3. Click OK to save the workbook and close the dialog.

Restore a Workbook

1. Use one of the following methods to restore a workbook:

� Select File > Open and select the workbook file you want to
restore. Click OK.

� Drag the workbook file from Windows Explorer View and
drop it on the data pane.

2. The Reconnect Links dialog appears, prompting you to select
Reconnect or Offline.

Reconnect. Select Reconnect to reconnect the links used when
the workbook was last saved.
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Offline. Select Offline to open the data sheet without restoring
the links to the original data sources.

NOTE. If you select Reconnect and the data source is no longer
available, a dialog will appear telling you so, and the workbook will
be opened as an Offline file (no active links).

3. If you have a workbook already open, you will be prompted to
save. Restoring a saved workbook file closes the current
workbook file.

Saving and Printing Repetitive Snapshots of Data
(“Babysitting” or Untended Monitoring Mode)

The Save, Print, and Refresh buttons in the main toolbar accept
linked data. This allows you to save, print, or refresh the data sheet
or workbook when the data source updates, even if you are not
sitting at your PC. Follow the steps below to link data sources to one
of these buttons:

1. Select a data sheet that has linked data. While you can link data
to a toolbar button directly from the Explorer View, dragging it
first to a data sheet allows you set the name of the saved data
sheet or workbook file.

2. If you plan to save repetitive snapshots of your data, you should
choose the Autoversioning option from the File menu. Selecting
this option adds an automatic date and timestamp to the saved
filename, which prevents new files from overwriting previous
ones.

3. Right click and drag the data source to the toolbar button. When
you release the mouse button, select Link in the shortcut menu
that pops up. (You can also press Ctrl+Shift and left click and
drag the data source to the toolbar button.)

To view or delete a link from a data sheet or toolbar button, right
click on the sheet or button and select Show Links from the shortcut
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menu that pops up. The Show Links dialog appears allowing you to
select and delete links.

Viewing Long Record Lengths

You can view and export long record lengths with up to 8 million
sample points. The procedure for viewing long record lengths is the
same as for viewing any waveform data, with the exception of the
PC memory required to download or export the data.

The following table lists memory requirements to download and
export waveform record lengths of 4 million and 8 million points.
Using less memory than the table indicates requires WaveStar to do
extensive disk cache swapping, resulting in process times from
minutes to hours. If you plan on working with long record length
files, install RAM into your PC to meet (or preferably exceed) the
minimum memory requirements listed in the table.

Record length

Minimum RAM re-
quired to download
from oscilloscope

Minimum RAM re-
quired to generate
export file

4 million points 48 MB 60 MB

8 million points 96 MB 120 MB

Follow the steps below to print the full record length of all
waveforms in the YT data sheet:

1. Select the data sheet.

2. Select File > Print Banner. The Print Banner option is useful
when your YT data sheet contains waveforms that are longer than
the width of the graticule.

Exporting Data

You can export data from any of the data sheets as either comma-
separated values (CSV), text, or rich text format (RTF). You can also
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export waveform mask test files (MSK) from YT data sheets. Refer
to Importing/Exporting a Mask on page 4--42.

1. Select the data sheet from which you want to export data.

2. Select the data items within the data sheet that you want to
export.

3. Select the File > Export menu command.

4. In the Export dialog, select the format for the exported data and
click OK.

� CSV: Comma-separated values

� Text: ASCII text format

� RTF: Rich text format

5. In the File Save As dialog, enter a file name and location for the
export file, and click OK.

While the export is running, a counter is displayed that shows how
many records have been exported and written to the export file.
Click Stop at any time to stop the export. This is especially helpful
when exporting long record lengths.

When displayed, data in the export file looks exactly like what you
would get if you dragged and dropped the data to Microsoft Excel or
Word, except using the Export command writes this data to a file
instead of displaying it in an external application.

Converting .SHT files to .CSV files

The File Conversion utility (File > File Conversion) converts all
saved DataSheet (.sht) files (except NoteSheets) in a directory to
Coma Separated Values (CSV) files. The utility generates the CSV
files (.csv) in the same directory using the same names as the .sht
files. The CSV file format is exactly the same as that of a CSV file
generated using File > Export DataSheet > To CSV, except that this
utility converts all .sht files in a directory in one step.
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To start the batch conversion utility, do the following steps:

1. Close any open data sheet windows.

2. Select File > File Conversion. This menu item is only available
when all data sheets are closed. WaveStar displays a confirmation
dialog box. Select Yes to convert files, or No to cancel the utility.
Selecting Yes displays a browser window.

3. Navigate to and select the folder that contains the .sht files that
you want to convert to .csv files.

4. Select OK. The conversion utility converts all .sht files in the
directory and displays a message stating how many files were
converted. If no .sht files are in the selected directory, the utility
indicates that no .sht files were in the selected directory.

Importing Data

You can import instrument-generated WFM, ISF, or CSF-format
waveforms files, as well as waveform data stored or created in
Microsoft Excel CSV format. You can import waveform data to YT,
XY, WaveformMeasurement, and WaveFormTabular data sheets.
You can also import waveform mask test files (MSK) to YT data
sheets. Refer to Importing/Exporting a Mask on page 4--42.

Importing data method 1:

1. Select the data sheet to which you want to import data.

2. Select the File > Import command. WaveStar displays the
Import File dialog box.

3. Select or enter the name of the file to import.

4. Click OK. WaveStar imports the data into the selected data sheet.

Importing data method 2:

1. In the Windows environment, select the file that contains the
waveform data to import.

2. Drag and drop the file onto the data sheet to which you want to
import data.
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The CSV File Format

CSV files can have no more than two lines of header information,
followed by two columns of time/value data. The following is an
example of the CSV format:

[YTSheet (1).CH1]
S,Volts
-0.024984,0.108438
-0.024944,0.0615625
-0.024904,0.090625
...
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User Proxy Table Utility

The WaveStar User Proxy Table Creation Utility is an application
that helps you build instrument proxy files interactively. Instrument
proxy files consist of simple commands and queries that the utility
uses to program those instruments for which instrument proxies are
not available. You can use this utility with WaveStar Software for
Oscilloscopes.

Proxy File Overview

Instrument Proxy files are user-readable ASCII files, with read and
write permissions enabled. Each file consists of records that describe
the commands and queries to be used to program various settings in
the instrument. The records can also contain information on the data
type of any argument taken by the command, the response string that
will be returned by the query and read/write privileges.

The proxy table files can only contain commands and queries that
take or return simple, nonaggregate data. Commands and queries
that handle aggregate data, like arrays or structures, cannot be used
in the file.

Records

A typical record in the file will look as follows:

add(CH1.Bandwidth), command(:CH1:BAN%s\n),
query(:CH1:BAN?\n), response(%s), type(String),
access(rw), enum(TWENTY,HUNDRED,FULL);

In the above example, the name of the setting described by the
record is CH1.Bandwidth. The string to be used to program the
setting is specified by the Command field. The string to be used to
query the setting is specified by the Query field. The Type field
specifies the nature of the argument taken by the command. Access
rights are specified by the Access field.
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Fields within a record are separated by commas, while records
themselves are separated by semi-colons.

Initialization Commands

You can specify a set of initialization commands in the file, which
the WaveStar application will use to initialize the instrument during
the process of establishing a connection. Initialization commands are
preceded by the keyword ‘init’, while normal commands are
preceded by the keyword ‘add’.

A typical initialization command looks as follows:

init(:CH1:BAN TWENTY\n);

The WaveStar application will issue the above statement to the
instrument at the time of establishing the connection, setting the
instrument bandwidth to TWENTY. You can specify multiple
initialization records, but you must separate them with semi-colons.
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Main Screen

When you open the User Proxy Table Utility, the application opens
the main screen. This dialog is used to add a new record or modify
an existing record. For a new file, the list box and controls will be
empty. If you open an existing file the list box will display the
records in the file and the controls show corresponding fields of the
first record. The columns of the list box correspond to the different
fields comprising a record.

Menu bar

Toolbar

Controls

Record
list box
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File Menu

New. Select New to open a new main screen with no records in the
list box. The application can open only one file at a time, so if you
select New, the currently open file will be closed (you will be
prompted to save this file before it is closed). By default, new files
are titled Instrument 1.

Open. Select Open to open a previously saved file.

Save. Select Save to save the open file to a directory. Files are saved
with an .ipr extension.

Save As. Select Save As to save the open file with a new name or in a
new location.

Settings. Select Settings to open the User Proxy Registry Settings
dialog. See Registry Screen on page 6--9 for further information.

<Recent Files>. This section of the File menu displays all recently
opened files.

Exit. Select Exit to close the application.
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Record Menu

New. Select New in the Record menu to commit (save) the current
record and clear the controls for entering a new record. If you were
modifying the current record, you must first click Update to update
the record file; otherwise the modifications will be lost. Records are
saved to file in the same order they are displayed in the list box.

Cut. Select Cut to cut the selected record from the list box. The cut
record is put on the clipboard.

Copy. Select Copy to copy the selected record.

Paste. Select Paste to paste the record in the clipboard to the list box.
The record is pasted above the currently selected record in the list
box.

Initialization Record. Select Initialization Record to open the
Initialization Commands dialog. See Initialization Screen on page
6--8 for further information.

Home. Select Home to select the first record in the file and show the
corresponding controls.

End. Select End to select the last record in the file and show the
corresponding controls.
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Help Menu

Select About Proxytbl... in the Help menu to display the About
Proxytbl dialog showing the product name, version number, and
copyright information.

Toolbar

1 2 3 4 5 6 7 8

1

2
3

4
5
6
7

8

New file

Open a file

Save file

Move to first record in list

Move to previous record in list

Display About Proxytbl dialog

Move to next record in list

Move to last record in list

Toolbar Buttons

There are four toolbar buttons in the main screen that control the
current record (see the illustration on page 6--3):

New. Click this button to insert a new, blank record above the
currently selected record.

Update. Click this button to commit (save) the current record. Any
changes you have made in the controls will appear in the list box.

Clear. Click this button to clear the edit controls and entry fields.

Cut. Click this button to cut the currently selected record from the list
box. The cut record is placed on the Windows clipboard.

Control Settings

There are nine control settings in this dialog that allow you to
control the record.
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Setting. This control specifies the name of the instrument setting
described by the record.

Command. This control specifies the command to be used to program
the setting in the instrument. The command control is disabled if the
access control is set to read-only.

Query. This control specifies the query to be used to read the setting
from the instrument. If you do not specify a query control, the
response control is disabled. The query control is disabled if the
Access control is set to write-only or execute.

Response. This control specifies the type of response expected when
the setting is queried. This control is disabled if no query control is
specified.

Access. This control specifies the read/write access of the setting.
Settings with write-only access cannot be queried. You can not write
to settings with read-only access. Read settings disable the command
control. Write settings disable the query and response controls.
Execute settings set the Data type control to Method and disable all
controls except Setting, Command, and Data Type.

Data Type. This control specifies the type of argument that the
Command control will take. For Method data type settings, the
Access control is set to Execute.

Enum List. This control is used to input comma-separated enumerated
values. These values must be comma-separated.

Units. This control specifies the units to be associated with the
setting.

List Box. The list box displays the partial set of records in the
currently open file. You can view any record in the file by selecting
the record in the scrolling list.
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Initialization Screen

The Initialization Commands dialog has a scrollable edit box that
displays initialization commands that have been previously entered
or read from the Initialization Section of the file.

You can add, delete, and modify the initialization commands. Each
command has to be entered on a new line. Click OK to save the
initialization commands and store and add them to the Initialization
Section of the file when the file is saved. Click Cancel to dismiss the
dialog without saving changes.
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Registry Screen

Use the User Proxy Registry Settings dialog to enter registration
information for the file. You can access the Registry Settings by
selecting Settings from the File menu. The dialog is also displayed
when you save or close the file.

If there is an entry for the current file in the registry, the values in
this entry are read and displayed in the dialog; otherwise the dialog
is brought up with default values in the fields. You can modify these
values and overwrite the existing registry entries.

At startup, the application checks the registry to see if there is any
top-level key containing the UserProxyProgId (“UIser.InstrConnec-
tion.1”) and Type (0x796e6164). If such key is unavailable, the
utility creates it, and updates LastProxyId. If necessary, the
application builds the whole Software\Tektronix\InstSvr\Available
Proxies tree under HKEY_LOCAL_MACHINE key.

NOTE. If there is no registry entry under the UserProxy top-level key
corresponding to the file name being edited, the application creates a
new entry with the same name as the open file and saves the settings
under it.
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There are four entry fields and two buttons that control the User
Proxy Registry Settings dialog:

� Instrument Family Member Name: This field displays the name of
the file that is being registered.

� VISA Filter: This is a user-editable field that shows the value of the
VisaFilter registry key if available. This key determines the
communication (GPIB or RS-232) settings of the instrument. If
this registry key is not available, this field shows, by default,
GPIB?*INSTR:ASRL?*INSTR.

� VISA Defaults: This is a user-editable field that shows the value of
the VisaDefaults registry key if available. This key determines
the default RS-232 baud rate, data bits, parity, and flow control
settings of the instrument. If this registry key is not available, this
field shows, by default,
VI_ATTR_ASRL_BAUD=9600,VI_ATTR_
ASRL_DATA_BITS=8,VI_ATTR_ASRL_PARITY=0,
VI_ATTR_ASRL_FLOW_CNTRL=2.

� VISA Settings: This is a user-editable field that shows the value of
the VisaSettings registry key, if available. This key determines
the user-edited baud rate, data bits, parity, and flow control
settings of the instrument. If this registry key is not available, this
field shows, by default,
VI_ATTR_ASRL_BAUD=9600,VI_ATTR_ASRL_
DATA_BITS=8,VI_ATTR_ASRL_PARITY=0,
VI_ATTR_ASRL_FLOW_CNTRL=2.

� OK Button: Click this button to save currently displayed registry
settings and close dialog.

� Cancel Button: Click this button to dismiss the dialog without
changing the registry settings.
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RS-232

This section provides instructions to set the default RS-232 values on
various Tektronix oscilloscopes and some general troubleshooting
help.

Setting RS-232 Default Values

Refer to the information in this section for RS-232 interface
connections for your specific oscilloscope family.

TDS200, TDS1000, TDS2000, TDS3000, TDS3000B, and THS700 Series

If you are using a TDS200, TDS1000, TDS2000, TDS3000,
TDS3000B, or THS700 Series oscilloscope, you can use the Set
RS-232 Parameters to Default Values button to set the RS-232
settings on the oscilloscope to the WaveStar default values.

TDS200, TDS1000, TDS2000 Series Oscilloscopes. Follow the steps
below to access the Set RS-232 Parameters to Default Values button:

1. Push the front-panel Utility button.

2. Push the Options bezel button.

3. Push the RS232 Setup bezel button.

4. Push the Set to defaults bezel button to set the RS-232 settings to
the WaveStar default settings.

You can examine the Error Log for information about your RS-232
interface connection. Follow the steps below to access the
TDS200 Series Error Log:

1. Push the front-panel Utility button.

2. Push the Error Log bezel button.

3. Use the bezel buttons to page through the Error Log display.
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Follow the steps below to access the TDS1000/2000 Series
Error Log:

1. Push the front-panel Utility button.

2. Push the Options bezel button.

3. Push the Error Log bezel button.

4. Use the bezel buttons to page through the Error Log display.

Check the lines in the Error Log titled RS-232 Line Snapshot and
RS-232 Errors. Refer to the programmer manual for your oscillo-
scope for information about interpreting the information in the Error
Log.

TDS3000/3000B Series Oscilloscopes. Follow the steps below to access
the Set RS-232 Parameters to Default Values button:

1. Push the front-panel Utility button.

2. Push the System button (bottom left bezel button) repeatedly
until I/O is selected.

3. Push the RS232 bezel button. The side bezel buttons now control
the RS-232 settings.

4. Push the fifth bezel button on the side to set the default RS-232
settings to the WaveStar default values.

You can examine the Error Log for clues about your RS-232
interface connection. Follow the steps below to access the Error Log:

1. Push the front-panel Utility button.

2. Push the bottom left bezel button on the oscilloscope repeatedly
until Diag is selected.

3. Push the Error Log bezel button to display the Error Log.

Check the lines in the Error Log titled RS-232 Line Snapshot and
RS-232 Errors. Refer to the programmer manual for your oscillo-
scope for information about interpreting the information in the
Error Log.
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THS 700 Series Oscilloscopes. Follow the steps below to access the Set
RS232 Parameters to Defaults button.

1. Push the front-panel Utility button.

2. Push the System Config bezel button repeatedly to select
RS-232.

3. Push the Set RS232 Parameters to Defaults bezel button.

You can examine the Error Log for clues about your RS-232
interface connection. Follow the steps below to access the Error Log:

1. Push the front-panel Utility button.

2. Push the bottom left bezel button on the oscilloscope repeatedly
until Diag is selected.

3. Push the Error Log bezel button.

4. Push the adjacent bezel button labeled OK Display Log to
display the Error Log.

Check the lines in the Error Log titled RS-232 Line Snapshot and
RS-232 Errors. Refer to the programmer manual for your oscillo-
scope for information about interpreting the information in the Error
Log.

TDS400, 500, 600, or 700 Series

The TDS400, 500, 600, and 700 Series oscilloscopes support RS-232
printers but cannot be controlled over the RS-232 interface.
WaveStar Software can only communicate with these series of
oscilloscopes using a GPIB interface connection.
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RS-232 General Hints

� Make sure the communication parameters are set correctly on
both the oscilloscope and WaveStar. Baud rates should be the
same, Parity should be None, Data Bits should be 8, and
Stop Bits should be 1.

NOTE. Soft flagging should never be used for waveform and
hardcopy transfers. This is because waveform data and hardcopy
output contain binary characters which can easily include the XON
and XOFF characters used to implement soft flagging. Soft flagging
should only be used for transferring stored setups since stored setup
information generally consists of printable ASCII text.

� Although it generally should not matter if the EOL characters are
the same, set the EOL to CRLF to be sure there are no problems.

� Not all instruments support full RS-232 communications. Some
instruments only support GPIB communication, while others
support limited RS-232 functions, such as printer functions.

� If you are able to connect to an instrument but unable to transfer
waveforms successfully, you may have a cable that is not wired
correctly for hard flagging.

If you can successfully transfer settings to and from the
instrument at the fastest supported baud rate, hard flagging is
probably working. If not, try soft flagging. If you can successful-
ly transfer settings using soft flagging but not with hard flagging,
there is a good chance the hard flagging lines of your cable are
not connected properly.
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RS-232 Cable Issues

If the information provided so far in this section fails to resolve your
RS-232 problems, try the following information:

� You might be using an incompatible RS-232 cable. There is no
such thing as a standard RS-232 cable, so you may need to use an
ohmmeter to verify that your cable is wired correctly. Many
cables do not have all of the pins connected.

� Determine whether the PC and oscilloscope are DTE (Data
Terminal Equipment) or DCE (Data Communications Equip-
ment) devices. This information is in the documentation provided
with your oscilloscope and with your PC.

� If you are connecting a DTE device to a DCE device you will
need a straight-through cable. This is a cable that has the same
pin assignments on both ends of the cable.

� If you are connecting two devices of the same type, you need a
null modem cable. This is a cable whose lines are crossed such
that the inputs of one device are connected to the outputs of the
other.

CAUTION. Do not connect the output lines of two same-type devices
to each other. Doing so will damage one or both of the devices.

� For hard flagging to work, the RTS (Request To Send) and CTS
(Clear To Send) lines must be connected. Use an ohmmeter to
verify that they are actually connected since not all cables
connect these lines. The RTS line is sometimes referred to as
RFR.

� The DCD (Data Carrier Detect) line is not used by WaveStar so it
does not matter whether or not it is connected. The DCD line is
sometimes referred to as RLSD.



RS-232

7- 6 WaveStar Software User Manual

RS-232 Cable Examples

The information in this section provides correct wiring and pin
assignments for RS-232 interface connections with each type of
oscilloscope supported by WaveStar Software.

TDS200 & TDS3000 Series Oscilloscope to PC (DB9 to DB9 )

Table 7--1 lists the correct wiring for connecting a TDS200 or
TDS3000 Series oscilloscope with 9 pins to a 9 pin serial port on a
DTE PC. These oscilloscopes are DTE devices.

Table 7- 1: Pin assignments for TDS200, TDS 300, and TDS3000 Series
oscilloscopes (DB9 to DB9)

TDS line

DB9 connec-
tor pin
number (to
oscilloscope)

DB9 con-
nector pin
number
(to PC) DB9 signal name

(RxD) 2 3 (TxD)

(TxD) 3 2 (RxD)

(DTR) 4 6 (DSR)

(GND) 5 5 (GND)

(DSR) 6 4 (DTR)

(RTS) 7 1, 81 (CTS)

(CTS) 8 7 (RTS)

1 Pins 1 and 8 are wired together.
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Connecting Two Like Devices (DCE to DCE or DTE to DTE)
Using Null Modem Cable

Table 7--2 lists the correct wiring for connecting two like devices
together using a DB25 female to DB25 female cable.

Table 7- 2: Pin assignments for DB25 Female to DB25 Female Null
Modem Cable

DB25 female 25 pin
connector

DB25 fe-
male pin
number PC pin Line name

Chassis Ground 1 1 Chassis Ground

(TxD) 2 3 (RxD)

(RxD) 3 2 (TxD)

(RTS) 4 5 (CTS)

(CTS) 5 4 (RTS)

(DSR DCD) 6,81 20 (DTR)

(DTR) 20 6,81 (DCR DCD)

(Signal GND) 7 7 (Signal GND)

1 Pins 6 and 8 are wired together.
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GPIB Overview

Most GPIB problems are caused by the general errors listed in
Table 8--1 lists common GPIB problems and .

Table 8- 1: Common GPIB Errors

Problem Solution

Loose Cable Make sure cables are securely connected to both
the PC and the oscilloscope.

Wrong GPIB Address Make sure you have selected the correct address.
WaveStar provides addresses 1 through 30. Check
the GPIB address of your instrument. The address
is an instrument function, so refer to your instrument
user manual for instructions on how to check and
set the instrument’s GPIB address.

Multiple devices using
the same GPIB address

Make sure each instrument connected to the GPIB
bus has a unique GPIB address.

Timeout Value too Slow Set the time-out value to a faster time.

Windows GPIB Drivers
not Installed

Install the proper Windows GPIB drivers.

Old Version of GPIB
Drivers

Upgrade to National Instruments Version 2.7.2 or
later.
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If you experience problems using GPIB communication, use the
steps below to try to resolve the problem. Usually, problems have a
simple cause such as an incorrect address or faulty cable. If the
procedures below or other GPIB-related help information does not
fix the problem, contact Tektronix Technical Support for further
help.

First, make sure you are using the proper equipment to establish the
GPIB connection:

� National Instruments GPIB Interface card (IEEE Std 488.2)
Version C.12 or later

� GPIB Cable

After verifying you are using the proper GPIB equipment, follow the
steps below.

1. Disconnect all GPIB cables from PC.

2. Run the hardware diagnostics supplied with the GPIB card.

3. Run the software diagnostics supplied with the card.

4. If the GPIB diagnostics fail, or if you have difficulty running
them, contact National Instrument Technical Support.

5. If the GPIB diagnostics pass, contact Tektronix. (See the Preface
for information on how to contact Tektronix.)
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Index

A

address, Tektronix, vii

B

babysitting/untended monitoring,
5--12

baud rate, 2--6

C

changing
waveform color, 5--4
waveform position, 5--4
waveform scale, 5--4

communication, PC to instrument,
1--5

configuring TekVISA, 1--6
connect to instrument, 5--10
contacting Tektronix, vii
converting .sht files to .csv format,

5--14
copy, instrument setups, 4--13
copying
data, 4--4
data to a data sheet, 3--15
instrument screen, 5--8
screen image to another applica-

tion, 5--9
creating a new mask, 4--40
CSV file format, 5--16
cursors, using, 5--7

D

data, linking, 3--16, 4--4
data bits, 2--7
data sheet
common behavior, 4--1
compatible data between sheets,

4--6
property sheets, 4--5
YT, 4--32

data sheet pane, 3--2, 4--1
datalog measurement sheet
copying vs. linking, 4--8
I/O operations, 4--8
overview, 4--7
property sheet, 4--8
start recording, 4--8
stop recording, 4--8

datalog tabular sheet
copying vs. linking, 4--10
I/O operations, 4--10
overview, 4--9
property sheet, 4--10
start recording, 4--9
stop recording, 4--9

displaying
trigger point, 5--5
two waveforms in XY sheet, 5--2
waveform is YT sheet, 5--1

drag and drop data to waveform
measurement sheet, 5--7

dynamically position waveforms,
5--3
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E

edit menu, 3--6
editing mask parameters, 4--41, 5--6
editing masks, 4--34
Explorer view, 3--2
data icon, 3--12
functions icon, 3--13
icons, 3--12
links, selections, properties, 3--18
setup icon, 3--13

export, 5--13

F

file menu, 3--4
flow control, 2--7

G

GPIB
common errors, 8--1
resolving problems, 8--2
terminator, 2--7
timeout rate, 2--7

graticule properties, 5--5

H

hardcopy, remote, 4--13
help menu, 3--9

I

importing waveform data, 5--15
installing WaveStar software, 1--5
instrument explorer
file utilities, 4--12
hardcopy, 4--13
overview, 4--11
setups, 4--13

Instrument Manager Service (IMS),
1--8

activity log
display, 2--10
print, 2--10

adding an instrument connected
to the AD007 Adapter, 2--5

main screen overview, 2--1
menu bar, 2--2
removing an instrument, 2--9
set instrument permissions, 2--11
shutting down service, 2--10
switching instrument online or

offline, 2--9
toolbar, 2--4
troubleshooting connection prob-

lems, 1--9

K

key, for installation, vi

L

linking data, 3--16, 4--4
lock horizontal scale, 5--5
lock trigger points, 5--5
long record lengths, 5--13
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M

mask editing, 4--34
mask parameters, editing, 4--41
mask, creating new, 4--40
Masks menu, 3--8, 3--9
measure strip chart plot using

cursors, 5--7
menus, toolbar, 3--10
Microsoft Office, copying data

into, 4--5
moving files, 4--12

N

notes sheet
overview, 4--14
saving/recalling instrument set-

tings, 4--16
supported applications, 4--15

O

offline, switching an instrument,
2--9

online, switching an instrument,
2--9

P

parameters, mask; editing, 4--41,
5--6

parity, 2--7
permissions, set for instrument,

2--11
phone number, Tektronix, vii
power harmonics, 4--17
print banner, 4--34
printing full record length, 4--34

procedures
babysitting/untended monitoring,

5--12
change graticule properties, 5--5
change waveform plot style, 5--6
change waveform position, 5--4
change waveform scale, 5--4
connect to instrument, 5--10
converting .sht files to .csv for-

mat files, 5--14
copy instrument screen, 5--8
copy screen image to another

application, 5--9
display trigger point, 5--5
display two waveforms in XY

sheet, 5--2
display waveform in YT sheet,

5--1
drag and drop data to waveform

measurement sheet, 5--7
dynamically position waveforms,

5--3
exporting data, 5--13
importing waveform data, 5--15
lock horizontal scale, 5--5
lock trigger points, 5--5
measure strip chart plot using

cursors, 5--7
restore data sheet, 5--10
restore waveform to instrument,

5--9
restore workbook, 5--11
save and print repetitive data,

5--12
save data sheet, 5--10
save workbook, 5--11
set up data source, 5--7
using cursors, 5--7
viewing long record lengths,

5--13
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zoom, 5--3
product support, contact informa-

tion, vii
properties, setting, 4--5

R

Reader, 3--19
reconnect links, 5--10
registration card, vi
remote hardcopy, 4--13
removing an instrument from IMS,

2--9
requirements, system, 1--3
restore data sheet, 5--10
restore waveform to instrument,

5--9
restore workbook, 5--11
RS-232
baud rate, 2--6
cable examples by product fami-

ly, 7--6
cable issues, 7--5
changing instrument settings, 7--1
data bits, 2--7
flow control, 2--7
general hints, 7--4
parity, 2--7
stop bits, 2--7
terminator, 2--7
timeout rate, 2--7

S

save and print repetitive data, 5--12
save data sheet, 5--10
save workbook, 5--11

scalar viewer sheet
I/O operations, 4--21
overview, 4--21
property sheet, 4--22
supported applications, 4--22

service support, contact informa-
tion, vii

set up data source, 5--7
setting properties, 4--5
setups, 4--13
.sht file conversion utility, 5--14
software license, vi
Start/Stop data acquisition, 4--2
stop bits, 2--7
strip chart, zooming, 4--3
stripchart sheet
copying vs. linking, 4--24
I/O operations, 4--24
overview, 4--22
property sheet, 4--25
start recording, 4--24
stop recording, 4--24
using cursors, 4--25

support, contacting, vii
switching an instrument online or

offline, 2--9
system requirements, 1--3

T

technical support, vii
contact information, vii

Tektronix, contacting, vii
TekVISA configuration, 1--6
terminator, 2--7
timeout rate, 2--7
toolbar, 3--10
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troubleshooting
RS--232 cable issues, 7--5
RS--232 hints, 7--4

troubleshooting IMS problems, 1--9

U

uninstalling WaveStar, 1--10
URL, Tektronix, vii
user proxy table utility
control settings in the main

screen, 6--6
fields in user proxy registry

settings, 6--10
file menu, 6--4
help menu, 6--6
initialization commands, 6--2
initialization screen, 6--8
main screen overview, 6--3
proxy file overview, 6--1
record menu, 6--5
records, 6--1
registry screen, 6--9
toolbar, 6--6

using cursors, 5--7

V

view menu, 3--7

W

waveform measurement sheet
I/O operations, 4--25
overview, 4--25
property sheet, 4--27
supported applications, 4--27

waveform plot style, 5--6
waveform tabular sheet
I/O operations, 4--28
overview, 4--27
property sheet, 4--29

WaveStar
Explorer view, 3--12
main screen, 3--1
menu bar, 3--4
Reader, 3--19
toolbar, 3--10
uninstalling, 1--10

web site address, Tektronix, vii
window menu, 3--9

X

XY sheet
I/O operations, 4--30
overview, 4--30
property sheet, 4--31
using cursors, 4--31
zooming, 4--3
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Y

YT sheet
changing waveform scale, 4--33
cursors, 4--34
mask editing, 4--34
overview, 4--32
print banner, 4--34
property sheet, 4--33

selecting mask color, 4--36
selecting waveform color, 4--33
waveform operations, 4--32
zooming, 4--3

Z

zoom, 5--3
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